aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Maria Matejka <mq@ucw.cz>2018-12-17 12:45:21 +0100
committerMaria Matejka <mq@ucw.cz>2019-02-20 22:30:53 +0100
commit02dcbf343d94dd548605c5efbf724f89d81d7258 (patch)
treea9a1adb34db23a49c2b1e95b574b1172a9375b3c /configure.ac
parenta946317fab9776754192f679f38cb7789050c52d (diff)
downloadbird-02dcbf343d94dd548605c5efbf724f89d81d7258.tar.gz
Configure: Don't check for implicit fallthrough unless when debugging.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da1a8f44..33bc9101 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,6 +364,9 @@ if test "$enable_debug" = yes ; then
AC_CHECK_LIB([efence], [malloc])
fi
fi
+else
+ BIRD_CHECK_GCC_OPTION([bird_cv_c_option_wno_implicit_fallthrough], [-Wno-implicit-fallthrough])
+ BIRD_ADD_GCC_OPTION([bird_cv_c_option_wno_implicit_fallthrough], [-Wno-implicit-fallthrough])
fi
CLIENT=birdcl