aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaria Matejka <mq@ucw.cz>2019-02-08 13:38:12 +0100
committerMaria Matejka <mq@ucw.cz>2019-02-20 22:30:54 +0100
commit4f082dfa892e95f86ca8137410992a248110b6ef (patch)
treee5dbd45a36579f82da8de060d137980f4e2a651b /configure.ac
parent0a793ebc6059f4354c62ccec62ef7c950988ca4a (diff)
downloadbird-4f082dfa892e95f86ca8137410992a248110b6ef.tar.gz
Filter: merged filter instruction constructors, counting line size on instruction construct
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 33bc9101..850e771f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,12 @@ AC_ARG_ENABLE([debug],
[enable_debug=no]
)
+AC_ARG_ENABLE([debug-generated],
+ [AS_HELP_STRING([--enable-debug-generated], [enable this to abstain from generating #line @<:@no@:>@])],
+ [],
+ [enable_debug_generated=no]
+)
+
AC_ARG_ENABLE([memcheck],
[AS_HELP_STRING([--enable-memcheck], [check memory allocations when debugging @<:@yes@:>@])],
[],
@@ -156,7 +162,7 @@ test -z "$M4" && AC_MSG_ERROR([M4 is missing.])
AC_MSG_CHECKING([bison version])
BIRD_CHECK_BISON_VERSION(BISON_VERSION)
AC_MSG_RESULT([$BISON_VERSION])
-if test "$bird_bison_synclines" = yes; then
+if test "$bird_bison_synclines" = yes && test "$enable_debug_generated" = no; then
M4FLAGS="$M4FLAGS -s"
fi