aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Maria Matejka <mq@ucw.cz>2018-12-14 15:50:44 +0100
committerMaria Matejka <mq@ucw.cz>2018-12-18 14:55:29 +0100
commit78131eee64aeaf14cf418d6e5bf3f17ca602afb7 (patch)
treea39ca0a9abf5a9ea0b350b9efa6553b6fb63488c /configure.ac
parentbda5863425854cc1c705c6f428e952bafd01d2a1 (diff)
downloadbird-78131eee64aeaf14cf418d6e5bf3f17ca602afb7.tar.gz
Debug: support for -gdwarf-4 is not available everywhere
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ae2710f5..4dda60cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -343,7 +343,10 @@ fi
if test "$enable_debug" = yes ; then
AC_DEFINE([DEBUGGING], [1], [Define to 1 if debugging is enabled])
LDFLAGS="$LDFLAGS -rdynamic"
- CFLAGS="$CFLAGS -O0 -ggdb -g3 -gdwarf-4"
+ CFLAGS="$CFLAGS -O0 -ggdb -g3"
+
+ BIRD_CHECK_GCC_OPTION([bird_cv_c_option_dwarf4], [-gdwarf-4], [])
+ BIRD_ADD_GCC_OPTION([bird_cv_c_option_dwarf4], [-gdwarf-4])
AC_CHECK_HEADER([execinfo.h],
[