aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-18 13:29:38 +0200
committerOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-18 13:29:38 +0200
commit7d5e61a66a3d4ecd004f3aa44a3d1bd3682ccf07 (patch)
treec4e12f54bb719cb63060e5a5b689d533d635a92d /configure.ac
parent271fa063a3e2078d7a046146ac2da3718b080cfa (diff)
downloadbird-7d5e61a66a3d4ecd004f3aa44a3d1bd3682ccf07.tar.gz
Fix of the previous fix
Avoid empty macro argument to avoid default behavior.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 66e100df..9e375762 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,8 +222,8 @@ DAEMON_LIBS=
AC_SUBST(DAEMON_LIBS)
if test "$enable_libssh" != no ; then
- AC_CHECK_HEADER([libssh/libssh.h], [], [fail=yes], [ ])
- AC_CHECK_LIB([ssh], [ssh_connect], [], [fail=yes])
+ AC_CHECK_HEADER([libssh/libssh.h], [true], [fail=yes], [ ])
+ AC_CHECK_LIB([ssh], [ssh_connect], [true], [fail=yes])
if test "$fail" != yes ; then
AC_DEFINE([HAVE_LIBSSH], [1], [Define to 1 if you have the `ssh' library (-lssh).])