aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-17 16:05:07 +0200
committerOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-17 16:21:58 +0200
commit81edd3b3a78265b87c2ec6100dce852db5f40d2b (patch)
tree15dd4f82e25f12acfc5151a8690e7fcc96423e1b /configure.ac
parenta01e951d0fa452fea10a9faca0fbdc9c7cacff23 (diff)
downloadbird-81edd3b3a78265b87c2ec6100dce852db5f40d2b.tar.gz
Fix build on systems with dirty headers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2569a766..b352e039 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,7 +303,11 @@ case $sysdesc in
AC_CHECK_HEADER([linux/rtnetlink.h],
[],
[AC_MSG_ERROR([Appropriate version of Linux kernel headers not found.])],
- [] dnl Force new AC_CHECK_HEADER semantics
+ [
+ dnl Some older versions of Linux kernel headers require these includes
+ #include <asm/types.h>
+ #include <sys/socket.h>
+ ]
)
;;
esac
@@ -337,7 +341,7 @@ if test "$enable_client" = yes ; then
AC_CHECK_HEADERS([curses.h],
[],
[AC_MSG_ERROR([The client requires ncurses library. Either install the library or use --disable-client to compile without the client.])],
- [] dnl Force new AC_CHECK_HEADER semantics
+ [AC_INCLUDES_DEFAULT]
)
AC_SEARCH_LIBS([tgetent], [tinfo tinfow ncurses curses termcap],
@@ -348,7 +352,7 @@ if test "$enable_client" = yes ; then
AC_CHECK_HEADERS([readline/readline.h readline/history.h],
[],
[AC_MSG_ERROR([The client requires GNU Readline library. Either install the library or use --disable-client to compile without the client.])],
- [] dnl Force new AC_CHECK_HEADER semantics
+ [AC_INCLUDES_DEFAULT]
)
AC_SEARCH_LIBS([add_history], [history],