aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Maria Matejka <mq@ucw.cz>2018-07-17 15:30:59 +0200
committerJan Maria Matejka <mq@ucw.cz>2018-08-14 14:01:39 +0200
commit86b9e8e39a0b42407c95921ca8262b0a75cad5f2 (patch)
tree3d874e8d8e225205ad364c7911485b3fdeb67b73 /configure.ac
parent1279a83103262950ab99e8a6fe3c6cc2da8d42a8 (diff)
downloadbird-86b9e8e39a0b42407c95921ca8262b0a75cad5f2.tar.gz
M4: generate synchronization lines
This also includes Bison version check. Versions before 3.0 don't support them in a reliable way and we don't promise to work with versions older than 2.4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44184273..9a2e55e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,15 @@ test -z "$FLEX" && AC_MSG_ERROR([Flex is missing.])
test -z "$BISON" && AC_MSG_ERROR([Bison is missing.])
test -z "$M4" && AC_MSG_ERROR([M4 is missing.])
+AC_MSG_CHECKING([bison version])
+BIRD_CHECK_BISON_VERSION(BISON_VERSION)
+AC_MSG_RESULT([$BISON_VERSION])
+if test "$bird_bison_synclines" = yes; then
+ M4FLAGS="$M4FLAGS -s"
+fi
+
+AC_SUBST([M4FLAGS])
+
BIRD_CHECK_PROG_FLAVOR_GNU([$M4],
[],
[AC_MSG_ERROR([Provided M4 is not GNU M4.])]