aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaria Matejka <mq@ucw.cz>2020-07-22 00:09:15 +0200
committerMaria Matejka <mq@ucw.cz>2021-03-25 16:47:48 +0100
commit886dd92eeefa070d8db6aaf0245a67f7a9e9b983 (patch)
tree67911e19951d083c003e212578fae76d93deb01c /configure.ac
parent82f19ba95e421f00a8e99a866a2b8d9bbdba6cdc (diff)
downloadbird-886dd92eeefa070d8db6aaf0245a67f7a9e9b983.tar.gz
Slab: head now uses bitmask for used/free nodes info instead of lists
From now, there are no auxiliary pointers stored in the free slab nodes. This led to strange debugging problems if use-after-free happened in slab-allocated structures, especially if the structure's first member is a next pointer. This also reduces the memory needed by 1 pointer per allocated object. OTOH, we now rely on pages being aligned to their size's multiple, which is quite common anyway.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eabb3d56..7d92a5d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -351,6 +351,7 @@ case $sysdesc in
esac
AC_CHECK_HEADERS_ONCE([alloca.h syslog.h])
+AC_CHECK_HEADER([sys/mman.h], [AC_DEFINE([HAVE_MMAP], [1], [Define to 1 if mmap() is available.])])
AC_CHECK_MEMBERS([struct sockaddr.sa_len], [], [], [#include <sys/socket.h>])
AC_C_BIGENDIAN(