aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaria Matejka <mq@ucw.cz>2019-02-27 14:40:05 +0100
committerMaria Matejka <mq@ucw.cz>2019-02-27 14:40:05 +0100
commita68442e0563f5b756f9a7323cea44a25ce048738 (patch)
treeff6d96f142e5f3b351fc39fb01128107b4190756 /configure.ac
parentf249d0b84c840242a084966999a1d228c603b431 (diff)
downloadbird-a68442e0563f5b756f9a7323cea44a25ce048738.tar.gz
Fixed link time optimizer check for FreeBSD
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 7013a34e..58fdc7fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,22 +137,24 @@ if test "$bird_cflags_default" = yes ; then
BIRD_CHECK_GCC_OPTION([bird_cv_c_option_wno_missing_init], [-Wno-missing-field-initializers], [-Wall -Wextra])
BIRD_CHECK_GCC_OPTION([bird_cv_c_option_fno_strict_aliasing], [-fno-strict-aliasing])
BIRD_CHECK_GCC_OPTION([bird_cv_c_option_fno_strict_overflow], [-fno-strict-overflow])
- if test "$enable_debug" = no; then
- BIRD_CHECK_GCC_OPTION([bird_cv_c_option_flto], [-flto])
- fi
CFLAGS="$CFLAGS -Wall -Wextra -Wstrict-prototypes -Wno-parentheses"
BIRD_ADD_GCC_OPTION([bird_cv_c_option_wno_pointer_sign], [-Wno-pointer-sign])
BIRD_ADD_GCC_OPTION([bird_cv_c_option_wno_missing_init], [-Wno-missing-field-initializers])
BIRD_ADD_GCC_OPTION([bird_cv_c_option_fno_strict_aliasing], [-fno-strict-aliasing])
BIRD_ADD_GCC_OPTION([bird_cv_c_option_fno_strict_overflow], [-fno-strict-overflow])
- if test "$enable_debug" = no; then
- BIRD_ADD_GCC_OPTION([bird_cv_c_option_flto], [-flto])
- fi
fi
AC_MSG_CHECKING([CFLAGS])
AC_MSG_RESULT([$CFLAGS])
+if test "$enable_debug" = no; then
+ BIRD_CHECK_LTO
+fi
+
+if test "$bird_cv_c_lto" = yes; then
+ CFLAGS="$CFLAGS -flto"
+ LDFLAGS="$LDFLAGS -flto"
+fi
AC_PROG_CPP
AC_PROG_INSTALL