aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@toke.dk>2021-04-01 19:20:13 +0200
committerOndrej Zajicek (work) <santiago@crfreenet.org>2021-06-06 16:26:06 +0200
commitc48ebde5ce6db3da8cd571d213d1a1f265de8983 (patch)
treee465e1372465923b1123fd3957218eae84432868 /configure.ac
parent91d04583891f7a6f4aee612cf3f143cc84a73991 (diff)
downloadbird-c48ebde5ce6db3da8cd571d213d1a1f265de8983.tar.gz
sysdep: Add wrapper to get random bytes
Add a wrapper function in sysdep to get random bytes, and required checks in configure.ac to select how to do it. The configure script tries, in order, getrandom(), getentropy() and reading from /dev/urandom.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d92a5d4..ded258d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -374,6 +374,10 @@ elif test "$bird_cv_lib_log" != yes ; then
LIBS="$LIBS $bird_cv_lib_log"
fi
+AC_CHECK_FUNCS(getrandom)
+AC_CHECK_FUNCS(getentropy)
+AC_CHECK_HEADERS(sys/random.h)
+
if test "$enable_debug" = yes ; then
AC_DEFINE([DEBUGGING], [1], [Define to 1 if debugging is enabled])
LDFLAGS="$LDFLAGS -rdynamic"