aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaria Matejka <mq@jmq.cz>2018-04-23 15:54:20 +0200
committerJan Maria Matejka <mq@ucw.cz>2018-06-26 17:11:27 +0200
commitda16b33ab98602628d66ed4f434dc6fa76f338c6 (patch)
tree676643c38fa406d7014ce96ba37b53a97ab94433 /configure.ac
parentc2fc4c10ac81b8815c1434aa2b0945aa937df4fa (diff)
downloadbird-da16b33ab98602628d66ed4f434dc6fa76f338c6.tar.gz
Android: check for extra libs needed for build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4de8f93..44184273 100644
--- a/configure.ac
+++ b/configure.ac
@@ -315,6 +315,20 @@ AC_C_BIGENDIAN(
[AC_MSG_ERROR([Cannot determine CPU endianity.])]
)
+BIRD_CHECK_ANDROID_GLOB
+if test "$bird_cv_lib_glob" = no ; then
+ AC_MSG_ERROR([glob.h not found.])
+elif test "$bird_cv_lib_glob" != yes ; then
+ LIBS="$LIBS $bird_cv_lib_glob"
+fi
+
+BIRD_CHECK_ANDROID_LOG
+if test "$bird_cv_lib_log" = no ; then
+ AC_MSG_ERROR([don't know how to link syslog.])
+elif test "$bird_cv_lib_log" != yes ; then
+ LIBS="$LIBS $bird_cv_lib_log"
+fi
+
if test "$enable_debug" = yes ; then
AC_DEFINE([DEBUGGING], [1], [Define to 1 if debugging is enabled])
LDFLAGS="$LDFLAGS -rdynamic"