aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-17 17:03:36 +0200
committerOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-17 17:03:36 +0200
commitdab6706abad3be5b8efd44fe860689df44d20e83 (patch)
tree3937308dcec419d1529f965bbce4aa77eb705ba4 /configure.ac
parent81edd3b3a78265b87c2ec6100dce852db5f40d2b (diff)
downloadbird-dab6706abad3be5b8efd44fe860689df44d20e83.tar.gz
History lib may be integrated to Readline lib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b352e039..5d36d8e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,17 +355,18 @@ if test "$enable_client" = yes ; then
[AC_INCLUDES_DEFAULT]
)
- AC_SEARCH_LIBS([add_history], [history],
- [HISTORY_LIBS="$LIBS"; LIBS=""],
- [AC_MSG_ERROR([The client requires GNU Readline library. Either install the library or use --disable-client to compile without the client.])],
- )
-
AC_SEARCH_LIBS([rl_callback_read_char], [readline],
[READLINE_LIBS="$LIBS"; LIBS=""],
[AC_MSG_ERROR([The client requires GNU Readline library. Either install the library or use --disable-client to compile without the client.])],
[$TINFO_LIBS]
)
+ AC_SEARCH_LIBS([add_history], [history],
+ [HISTORY_LIBS="$LIBS"; LIBS=""],
+ [AC_MSG_ERROR([The client requires GNU Readline library. Either install the library or use --disable-client to compile without the client.])],
+ [$READLINE_LIBS $TINFO_LIBS]
+ )
+
AC_CHECK_LIB([readline], [rl_crlf],
[AC_DEFINE([HAVE_RL_CRLF], [1], [Define to 1 if you have rl_crlf()])],
[],
@@ -379,7 +380,7 @@ if test "$enable_client" = yes ; then
)
LIBS="$BASE_LIBS"
- CLIENT_LIBS="$READLINE_LIBS $HISTORY_LIBS $TINFO_LIBS"
+ CLIENT_LIBS="$HISTORY_LIBS $READLINE_LIBS $TINFO_LIBS"
fi
AC_SUBST([CLIENT])
AC_SUBST([CLIENT_LIBS])