aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-09 17:37:38 +0200
committerOndrej Zajicek (work) <santiago@crfreenet.org>2017-05-09 17:37:38 +0200
commitfd1f355b7b24f354f7d57f127911b4fd98354b34 (patch)
treedf857122e33422c4e72057b4a301f9cec61363bd /configure.ac
parent525a88d87930d01d4301e2723dda3dca208cd3d4 (diff)
parent71652572e35bfeea2f346b7c700a3050bf27e466 (diff)
downloadbird-fd1f355b7b24f354f7d57f127911b4fd98354b34.tar.gz
Merge branch 'master' into int-new
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 2 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 52bca085..de612ec2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,28 +218,11 @@ case $sysdesc in
esac
AC_CHECK_HEADERS_ONCE([alloca.h syslog.h])
+AC_CHECK_MEMBERS([struct sockaddr.sa_len], [], [], [#include <sys/socket.h>])
+
AC_CHECK_HEADER([linux/lwtunnel.h], [AC_DEFINE([HAVE_LWTUNNEL], [1], [Define to 1 if you have the <linux/lwtunnel.h> header file.])])
AC_CHECK_MEMBERS([struct rtvia.rtvia_family], [AC_DEFINE([HAVE_STRUCT_RTVIA], [1], [Define to 1 if you have rtvia structure.])],,[#include <linux/rtnetlink.h>])
-AC_MSG_CHECKING(whether 'struct sockaddr' has sa_len)
-AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM(
- [[
- #include <sys/types.h>
- #include <sys/socket.h>
- ]],
- [[
- static struct sockaddr sa;
- int i = sizeof(sa.sa_len);
- ]]
- )],
- [
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_SIN_LEN,,sin_len)
- ],
- [AC_MSG_RESULT(no)]
-)
-
AC_C_BIGENDIAN(
[AC_DEFINE([CPU_BIG_ENDIAN], [1], [Define to 1 if cpu is big endian])],
[AC_DEFINE([CPU_LITTLE_ENDIAN], [1], [Define to 1 if cpu is little endian])],