summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name <you@example.com>2021-08-31 19:04:47 +0000
committerYour Name <you@example.com>2021-08-31 19:19:31 +0000
commit14ca571548a4888b3b029d32ba56ad78978a3ba8 (patch)
treea7f4e45108517797778d7d88132fef9fb9a64bf5
parent8a70e962b8c1d9eaa85bfb7526ff55053505627d (diff)
downloadlinux-debian-ky/5.14.0-rhe0.tar.gz
fix patchesky/5.14.0-rhe0
-rw-r--r--debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch47
-rw-r--r--debian/patches/debian/tools-perf-version.patch6
-rw-r--r--debian/patches/debian/version.patch8
-rw-r--r--debian/patches/series16
4 files changed, 16 insertions, 61 deletions
diff --git a/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch b/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
index d88c53d3e..a68669f43 100644
--- a/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
+++ b/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
@@ -464,20 +464,6 @@ upstream submission.
ret = or51211_load_firmware(fe, fw);
release_firmware(fw);
---- a/drivers/media/dvb-frontends/sp8870.c
-+++ b/drivers/media/dvb-frontends/sp8870.c
-@@ -304,10 +304,8 @@
-
- /* request the firmware, this will block until someone uploads it */
- printk("sp8870: waiting for firmware upload (%s)...\n", SP8870_DEFAULT_FIRMWARE);
-- if (state->config->request_firmware(fe, &fw, SP8870_DEFAULT_FIRMWARE)) {
-- printk("sp8870: no firmware upload (timeout or file not found?)\n");
-+ if (state->config->request_firmware(fe, &fw, SP8870_DEFAULT_FIRMWARE))
- return -EIO;
-- }
-
- if (sp8870_firmware_upload(state, fw)) {
- printk("sp8870: writing firmware to device failed\n");
--- a/drivers/media/dvb-frontends/sp887x.c
+++ b/drivers/media/dvb-frontends/sp887x.c
@@ -527,10 +527,8 @@
@@ -715,39 +701,6 @@ upstream submission.
printk(KERN_INFO "%s() firmware read %zu bytes.\n",
__func__, fw->size);
---- a/drivers/media/pci/ttpci/av7110.c
-+++ b/drivers/media/pci/ttpci/av7110.c
-@@ -1502,13 +1502,8 @@
- /* request the av7110 firmware, this will block until someone uploads it */
- ret = request_firmware(&fw, "dvb-ttpci-01.fw", &av7110->dev->pci->dev);
- if (ret) {
-- if (ret == -ENOENT) {
-- printk(KERN_ERR "dvb-ttpci: could not load firmware, file not found: dvb-ttpci-01.fw\n");
-- printk(KERN_ERR "dvb-ttpci: usually this should be in /usr/lib/hotplug/firmware or /lib/firmware\n");
-- printk(KERN_ERR "dvb-ttpci: and can be downloaded from https://linuxtv.org/download/dvb/firmware/\n");
-- } else
-- printk(KERN_ERR "dvb-ttpci: cannot request firmware (error %i)\n",
-- ret);
-+ if (ret == -ENOENT)
-+ printk(KERN_ERR "dvb-ttpci: firmware can be downloaded from https://linuxtv.org/download/dvb/firmware/\n");
- return -EINVAL;
- }
-
---- a/drivers/media/pci/ttpci/av7110_hw.c
-+++ b/drivers/media/pci/ttpci/av7110_hw.c
-@@ -235,11 +235,8 @@
- //saa7146_setgpio(dev, 3, SAA7146_GPIO_INPUT);
-
- ret = request_firmware(&fw, fw_name, &dev->pci->dev);
-- if (ret) {
-- printk(KERN_ERR "dvb-ttpci: Failed to load firmware \"%s\"\n",
-- fw_name);
-+ if (ret)
- return ret;
-- }
-
- mwdebi(av7110, DEBISWAB, DPRAM_BASE, fw->data, fw->size);
- release_firmware(fw);
--- a/drivers/media/platform/s5p-mfc/s5p_mfc_ctrl.c
+++ b/drivers/media/platform/s5p-mfc/s5p_mfc_ctrl.c
@@ -65,10 +65,8 @@
diff --git a/debian/patches/debian/tools-perf-version.patch b/debian/patches/debian/tools-perf-version.patch
index ccc28833d..dda7263a3 100644
--- a/debian/patches/debian/tools-perf-version.patch
+++ b/debian/patches/debian/tools-perf-version.patch
@@ -44,12 +44,14 @@ diff --git a/tools/perf/Makefile.perf b/tools/perf/Makefile.perf
index 86dbb51bb272..ed69643c3249 100644
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
-@@ -888,23 +888,23 @@ endif
+@@ -888,25 +888,23 @@ endif
install-tools: all install-gtk
$(call QUIET_INSTALL, binaries) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'; \
- $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)'; \
-- $(LN) '$(DESTDIR_SQ)$(bindir_SQ)/perf' '$(DESTDIR_SQ)$(bindir_SQ)/trace'
+- $(LN) '$(DESTDIR_SQ)$(bindir_SQ)/perf' '$(DESTDIR_SQ)$(bindir_SQ)/trace'; \
+- $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(includedir_SQ)/perf'; \
+- $(INSTALL) util/perf_dlfilter.h -t '$(DESTDIR_SQ)$(includedir_SQ)/perf'
+ $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)'; \
+ $(LN) '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)' '$(DESTDIR_SQ)$(bindir_SQ)/trace_$(VERSION)'
+ $(call QUIET_INSTALL, libexec) \
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index 917af7609..ba26d568c 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -157,15 +157,15 @@ are set.
*/
void dump_stack_print_info(const char *log_lvl)
{
-- printk("%sCPU: %d PID: %d Comm: %.20s %s%s %s %.*s\n",
-+ printk("%sCPU: %d PID: %d Comm: %.20s %s%s %s %.*s%s\n",
+- printk("%sCPU: %d PID: %d Comm: %.20s %s%s %s %.*s" BUILD_ID_FMT "\n",
++ printk("%sCPU: %d PID: %d Comm: %.20s %s%s %s %.*s" BUILD_ID_FMT "%s\n",
log_lvl, raw_smp_processor_id(), current->pid, current->comm,
kexec_crash_loaded() ? "Kdump: loaded " : "",
print_tainted(),
init_utsname()->release,
(int)strcspn(init_utsname()->version, " "),
-- init_utsname()->version);
-+ init_utsname()->version,
+- init_utsname()->version, BUILD_ID_VAL);
++ init_utsname()->version, BUILD_ID_VAL,
+ LINUX_PACKAGE_ID);
if (dump_stack_arch_desc_str[0] != '\0')
diff --git a/debian/patches/series b/debian/patches/series
index 96cc87908..73b0ee370 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -32,8 +32,8 @@ features/all/drivers-media-dvb-usb-af9005-request_firmware.patch
debian/iwlwifi-do-not-request-unreleased-firmware.patch
bugfix/all/firmware_class-log-every-success-and-failure.patch
bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
-bugfix/all/radeon-amdgpu-firmware-is-required-for-drm-and-kms-on-r600-onward.patch
-debian/firmware_class-refer-to-debian-wiki-firmware-page.patch
+# bugfix/all/radeon-amdgpu-firmware-is-required-for-drm-and-kms-on-r600-onward.patch
+# debian/firmware_class-refer-to-debian-wiki-firmware-page.patch
# Patches from aufs5 repository, imported with debian/bin/genpatch-aufs.
# These are only the changes needed to allow aufs to be built out-of-tree.
@@ -74,21 +74,21 @@ bugfix/x86/perf-tools-fix-unwind-build-on-i386.patch
bugfix/sh/sh-boot-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/arm/arm-mm-export-__sync_icache_dcache-for-xen-privcmd.patch
bugfix/powerpc/powerpc-boot-fix-missing-crc32poly.h-when-building-with-kernel_xz.patch
-bugfix/arm64/arm64-acpi-Add-fixup-for-HPE-m400-quirks.patch
+# bugfix/arm64/arm64-acpi-Add-fixup-for-HPE-m400-quirks.patch
bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
# Arch features
-features/arm64/arm64-dts-rockchip-Add-support-for-two-PWM-fans-on-h.patch
-features/arm64/arm64-dts-rockchip-Add-support-for-PCIe-on-helios64.patch
+# features/arm64/arm64-dts-rockchip-Add-support-for-two-PWM-fans-on-h.patch
+# features/arm64/arm64-dts-rockchip-Add-support-for-PCIe-on-helios64.patch
features/arm64/arm64-dts-rockchip-disable-USB-type-c-DisplayPort.patch
features/x86/x86-memtest-WARN-if-bad-RAM-found.patch
-features/x86/x86-make-x32-syscall-support-conditional.patch
+# features/x86/x86-make-x32-syscall-support-conditional.patch
# Miscellaneous bug fixes
bugfix/all/disable-some-marvell-phys.patch
bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
-debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
+# debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
bugfix/all/partially-revert-net-socket-implement-64-bit-timestamps.patch
# Miscellaneous features
@@ -116,7 +116,7 @@ bugfix/all/module-disable-matching-missing-version-crc.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch
-bugfix/all/kbuild-fix-recordmcount-dependency.patch
+# bugfix/all/kbuild-fix-recordmcount-dependency.patch
bugfix/all/tools-perf-man-date.patch
bugfix/all/tools-perf-remove-shebangs.patch
bugfix/x86/revert-perf-build-fix-libunwind-feature-detection-on.patch