summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2021-02-28 21:12:36 +0100
committerSalvatore Bonaccorso <carnil@debian.org>2021-02-28 21:13:28 +0100
commit908e080fcc6d00679cced1b92026759385164ad3 (patch)
tree051fb31431b2b12d78f22af071de8f785f86fec8
parent1fa76749a778d97471cea4e37b3e8344cff9117e (diff)
downloadlinux-debian-908e080fcc6d00679cced1b92026759385164ad3.tar.gz
[x86] drm/i915/gt: Flush before changing register state
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/x86/drm-i915-gt-Flush-before-changing-register-state.patch38
-rw-r--r--debian/patches/series1
3 files changed, 40 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 866bfae57..c0fa4a5e3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -350,6 +350,7 @@ linux (5.10.19-1) UNRELEASED; urgency=medium
* drm/nouveau: bail out of nouveau_channel_new if channel init fails
(CVE-2020-25639)
* [x86] drm/i915/gt: One more flush for Baytrail clear residuals
+ * [x86] drm/i915/gt: Flush before changing register state
[ Vincent Blut ]
* [x86] Enable PWM_CRC (Closes: #982808)
diff --git a/debian/patches/bugfix/x86/drm-i915-gt-Flush-before-changing-register-state.patch b/debian/patches/bugfix/x86/drm-i915-gt-Flush-before-changing-register-state.patch
new file mode 100644
index 000000000..9cf347227
--- /dev/null
+++ b/debian/patches/bugfix/x86/drm-i915-gt-Flush-before-changing-register-state.patch
@@ -0,0 +1,38 @@
+From: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Mon, 25 Jan 2021 22:02:47 +0000
+Subject: drm/i915/gt: Flush before changing register state
+Origin: https://cgit.freedesktop.org/drm-intel/commit/?id=d30bbd62b1bfd9e0a33c3583c5a9e5d66f60cbd7
+
+Flush; invalidate; change registers; invalidate; flush.
+
+Will this finally work on every device? Or will Baytrail complain again?
+
+On the positive side, we immediately see the benefit of having hsw-gt1 in
+CI.
+
+Fixes: ace44e13e577 ("drm/i915/gt: Clear CACHE_MODE prior to clearing residuals")
+Testcase: igt/gem_render_tiled_blits # hsw-gt1
+Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+Cc: Mika Kuoppala <mika.kuoppala@linux.intel.com>
+Cc: Akeem G Abodunrin <akeem.g.abodunrin@intel.com>
+Acked-by: Mika Kuoppala <mika.kuoppala@linux.intel.com>
+Link: https://patchwork.freedesktop.org/patch/msgid/20210125220247.31701-1-chris@chris-wilson.co.uk
+---
+ drivers/gpu/drm/i915/gt/gen7_renderclear.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/gpu/drm/i915/gt/gen7_renderclear.c b/drivers/gpu/drm/i915/gt/gen7_renderclear.c
+index 8551e6de50e8..e403eb046a43 100644
+--- a/drivers/gpu/drm/i915/gt/gen7_renderclear.c
++++ b/drivers/gpu/drm/i915/gt/gen7_renderclear.c
+@@ -393,6 +393,7 @@ static void emit_batch(struct i915_vma * const vma,
+ desc_count);
+
+ /* Reset inherited context registers */
++ gen7_emit_pipeline_flush(&cmds);
+ gen7_emit_pipeline_invalidate(&cmds);
+ batch_add(&cmds, MI_LOAD_REGISTER_IMM(2));
+ batch_add(&cmds, i915_mmio_reg_offset(CACHE_MODE_0_GEN7));
+--
+2.30.1
+
diff --git a/debian/patches/series b/debian/patches/series
index 4325714db..9dc573ee1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -77,6 +77,7 @@ bugfix/arm64/arm64-acpi-Add-fixup-for-HPE-m400-quirks.patch
bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
bugfix/mips/mips-support-binutils-configured-with-enable-mips-fi.patch
bugfix/x86/drm-i915-gt-One-more-flush-for-Baytrail-clear-residu.patch
+bugfix/x86/drm-i915-gt-Flush-before-changing-register-state.patch
# Arch features
features/arm64/arm64-dts-rockchip-Add-basic-support-for-Kobol-s-Hel.patch