summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2021-11-12 18:03:48 +0000
committerSalvatore Bonaccorso <carnil@debian.org>2021-11-12 18:03:48 +0000
commita41ed52e8e9a5247bef01bf07978ed266288ad30 (patch)
treeee87dbdf38152d1272ade81e859dfa5c2072df4d
parent8ed3fd8ae34094ce8c4afb8c9202b08898622250 (diff)
parent599848d9925dae72608b5e79dfaf2eefd4b1d734 (diff)
downloadlinux-debian-a41ed52e8e9a5247bef01bf07978ed266288ad30.tar.gz
Merge branch 'ptp_clock' into 'master'
Enable various PTP clock drivers See merge request kernel-team/linux!301
-rw-r--r--debian/changelog7
-rw-r--r--debian/config/config9
-rw-r--r--debian/config/kernelarch-x86/config1
3 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c295a292e..3a0307f05 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,13 @@ linux (5.15.1-1~exp2) UNRELEASED; urgency=medium
* [rt] Update to 5.15-rt17 and reenable (Closes: #995466)
* perf srcline: Use long-running addr2line per DSO (Closes: #911815)
+ [ Vincent Blut ]
+ * [x86] drivers/ptp: Enable PTP_1588_CLOCK_VMW as module
+ * drivers/ptp: Enable PTP_1588_CLOCK_DTE, PTP_1588_CLOCK_IDT82P33,
+ PTP_1588_CLOCK_IDTCM, PTP_1588_CLOCK_OCP as modules
+ * drivers/ptp, net: Enable DP83640_PHY, PTP_1588_CLOCK_INES,
+ NET_PTP_CLASSIFY, NETWORK_PHY_TIMESTAMPING
+
-- Salvatore Bonaccorso <carnil@debian.org> Thu, 11 Nov 2021 22:21:52 +0100
linux (5.15.1-1~exp1) experimental; urgency=medium
diff --git a/debian/config/config b/debian/config/config
index 1a9134e25..2295476cc 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -4568,7 +4568,13 @@ CONFIG_PPS_CLIENT_PARPORT=m
## file: drivers/ptp/Kconfig
##
CONFIG_PTP_1588_CLOCK=m
+CONFIG_PTP_1588_CLOCK_DTE=m
CONFIG_PTP_1588_CLOCK_QORIQ=m
+CONFIG_DP83640_PHY=m
+CONFIG_PTP_1588_CLOCK_INES=m
+CONFIG_PTP_1588_CLOCK_IDT82P33=m
+CONFIG_PTP_1588_CLOCK_IDTCM=m
+CONFIG_PTP_1588_CLOCK_OCP=m
##
## file: drivers/pwm/Kconfig
@@ -6776,7 +6782,8 @@ CONFIG_PAGE_POISONING=y
CONFIG_NET=y
CONFIG_INET=y
CONFIG_NETWORK_SECMARK=y
-# CONFIG_NETWORK_PHY_TIMESTAMPING is not set
+CONFIG_NET_PTP_CLASSIFY=y
+CONFIG_NETWORK_PHY_TIMESTAMPING=y
CONFIG_NETFILTER=y
CONFIG_NETFILTER_ADVANCED=y
CONFIG_BRIDGE_NETFILTER=y
diff --git a/debian/config/kernelarch-x86/config b/debian/config/kernelarch-x86/config
index 95359e18e..8acb9af76 100644
--- a/debian/config/kernelarch-x86/config
+++ b/debian/config/kernelarch-x86/config
@@ -1548,6 +1548,7 @@ CONFIG_INTEL_RAPL=m
##
CONFIG_PTP_1588_CLOCK_PCH=m
CONFIG_PTP_1588_CLOCK_KVM=m
+CONFIG_PTP_1588_CLOCK_VMW=m
##
## file: drivers/pwm/Kconfig