summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2022-07-19 18:17:32 +0200
committerBen Hutchings <benh@debian.org>2022-07-19 18:17:32 +0200
commit04cffb1672bce32ac7b0fe0ed4973836b3c4355b (patch)
tree933bdd7452488c998afbcfad9bf65bd9741bfc29 /debian/patches
parentdda97b5d4f471fcfa22d214a0d484a2847e61e6f (diff)
parent04d4869fd16e0c1be9d6c8a9778176a491670227 (diff)
downloadlinux-debian-04cffb1672bce32ac7b0fe0ed4973836b3c4355b.tar.gz
Merge branch 'add-rtla' to 'master'
[x86,arm64,armhf] Add rtla package for Real-Time Linux Analysis tools See merge request kernel-team/linux!512
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/bugfix/all/tools-rtla-build-with-extra-c-ld-flags.patch24
-rw-r--r--debian/patches/bugfix/all/tools-rtla-fix-command-symlinks.patch26
-rw-r--r--debian/patches/series2
3 files changed, 52 insertions, 0 deletions
diff --git a/debian/patches/bugfix/all/tools-rtla-build-with-extra-c-ld-flags.patch b/debian/patches/bugfix/all/tools-rtla-build-with-extra-c-ld-flags.patch
new file mode 100644
index 000000000..f64205079
--- /dev/null
+++ b/debian/patches/bugfix/all/tools-rtla-build-with-extra-c-ld-flags.patch
@@ -0,0 +1,24 @@
+From: Ben Hutchings <benh@debian.org>
+Date: Sat, 16 Jul 2022 15:00:01 +0200
+Subject: tools/rtla: Build with EXTRA_{C,LD}FLAGS
+Forwarded: https://lore.kernel.org/linux-trace-devel/YtLBshz0nMQ7530H@decadent.org.uk/T/
+
+To allow for distributions and other builders to apply hardening
+policy and other customisation, append EXTRA_CFLAGS and EXTRA_LDFLAGS
+to the corresponding variables.
+
+Signed-off-by: Ben Hutchings <benh@debian.org>
+---
+--- a/tools/tracing/rtla/Makefile
++++ b/tools/tracing/rtla/Makefile
+@@ -30,8 +30,8 @@ WOPTS := -Wall -Werror=format-security
+
+ TRACEFS_HEADERS := $$($(PKG_CONFIG) --cflags libtracefs)
+
+-CFLAGS := -O -g -DVERSION=\"$(VERSION)\" $(FOPTS) $(MOPTS) $(WOPTS) $(TRACEFS_HEADERS)
+-LDFLAGS := -ggdb
++CFLAGS := -O -g -DVERSION=\"$(VERSION)\" $(FOPTS) $(MOPTS) $(WOPTS) $(TRACEFS_HEADERS) $(EXTRA_CFLAGS)
++LDFLAGS := -ggdb $(EXTRA_LDFLAGS)
+ LIBS := $$($(PKG_CONFIG) --libs libtracefs)
+
+ SRC := $(wildcard src/*.c)
diff --git a/debian/patches/bugfix/all/tools-rtla-fix-command-symlinks.patch b/debian/patches/bugfix/all/tools-rtla-fix-command-symlinks.patch
new file mode 100644
index 000000000..5a6fdee1a
--- /dev/null
+++ b/debian/patches/bugfix/all/tools-rtla-fix-command-symlinks.patch
@@ -0,0 +1,26 @@
+From: Ben Hutchings <benh@debian.org>
+Date: Sat, 16 Jul 2022 15:20:27 +0200
+Subject: tools/rtla: Fix command symlinks
+Forwarded: https://lore.kernel.org/linux-trace-devel/YtLBXMI6Ui4HLIF1@decadent.org.uk/T/
+
+"ln -s" stores the next argument directly as the symlink target, so
+it needs to be a relative path. In this case, just "rtla".
+
+Fixes: 0605bf009f18 ("rtla: Add osnoise tool")
+Fixes: a828cd18bc4a ("rtla: Add timerlat tool and timelart top mode")
+Signed-off-by: Ben Hutchings <benh@debian.org>
+---
+--- a/tools/tracing/rtla/Makefile
++++ b/tools/tracing/rtla/Makefile
+@@ -108,9 +108,9 @@ install: doc_install
+ $(INSTALL) rtla -m 755 $(DESTDIR)$(BINDIR)
+ $(STRIP) $(DESTDIR)$(BINDIR)/rtla
+ @test ! -f $(DESTDIR)$(BINDIR)/osnoise || rm $(DESTDIR)$(BINDIR)/osnoise
+- ln -s $(DESTDIR)$(BINDIR)/rtla $(DESTDIR)$(BINDIR)/osnoise
++ ln -s rtla $(DESTDIR)$(BINDIR)/osnoise
+ @test ! -f $(DESTDIR)$(BINDIR)/timerlat || rm $(DESTDIR)$(BINDIR)/timerlat
+- ln -s $(DESTDIR)$(BINDIR)/rtla $(DESTDIR)$(BINDIR)/timerlat
++ ln -s rtla $(DESTDIR)$(BINDIR)/timerlat
+
+ .PHONY: clean tarball
+ clean: doc_clean
diff --git a/debian/patches/series b/debian/patches/series
index 550311549..700c4fb76 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -122,5 +122,7 @@ bugfix/all/tools-perf-fix-compilation-error-with-new-binutils.patch
bugfix/all/tools-bpf_jit_disasm-fix-compilation-error-with-new-binutils.patch
bugfix/all/tools-bpftool-fix-compilation-error-with-new-binutils.patch
bugfix/all/tools-perf-fix-build-without-libbfd.patch
+bugfix/all/tools-rtla-build-with-extra-c-ld-flags.patch
+bugfix/all/tools-rtla-fix-command-symlinks.patch
# ABI maintenance