summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/scripts/Makefile
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-02-19 20:05:58 +0000
committerBen Hutchings <ben@decadent.org.uk>2016-02-19 20:24:18 +0000
commit00337468627cb9042d6f87524c66ccd19869e75a (patch)
treee38008961352ec70a2de2b7ea0e1e08e90b57840 /debian/rules.d/scripts/Makefile
parente1fd4b6f1e2d2122072323a014ae4cd439c996e0 (diff)
downloadlinux-debian-00337468627cb9042d6f87524c66ccd19869e75a.tar.gz
Move makefile hierarchy to debian/rules.d; use debian/build for output only
By passing both -C and -f options to make, we can separate makefiles from the output directory without adding prefixes to all targets. We can also reduce the 'clean' commands to little more than 'rm -rf'.
Diffstat (limited to 'debian/rules.d/scripts/Makefile')
-rw-r--r--debian/rules.d/scripts/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/debian/rules.d/scripts/Makefile b/debian/rules.d/scripts/Makefile
new file mode 100644
index 000000000..8d9708771
--- /dev/null
+++ b/debian/rules.d/scripts/Makefile
@@ -0,0 +1,49 @@
+PROGS = \
+ conmakehash \
+ kallsyms \
+ pnmtologo \
+ recordmcount
+
+DATA = \
+ Kbuild.include \
+ Makefile.build \
+ Makefile.clean \
+ Makefile.extrawarn \
+ Makefile.host \
+ Makefile.kasan \
+ Makefile.lib \
+ Makefile.modinst \
+ Makefile.modpost \
+ mkversion \
+ module-common.lds
+
+SCRIPTS = \
+ checkincludes.pl \
+ checkstack.pl \
+ checkversion.pl \
+ depmod.sh \
+ gcc-goto.sh \
+ gcc-version.sh \
+ gcc-x86_32-has-stack-protector.sh \
+ gcc-x86_64-has-stack-protector.sh \
+ gen_initramfs_list.sh \
+ kernel-doc \
+ Lindent \
+ makelst \
+ mksysmap \
+ mkuboot.sh \
+ namespace.pl \
+ patch-kernel \
+ recordmcount.pl \
+ setlocalversion \
+ ver_linux
+
+SUBDIRS = \
+ basic \
+ genksyms \
+ kconfig \
+ mod
+
+include $(top_rulesdir)/Makefile.inc
+
+CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64