summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2022-07-29 01:04:28 +0200
committerBen Hutchings <benh@debian.org>2022-07-29 01:04:28 +0200
commit3e2278ca28895753f96482f5aa87ad7b705614ed (patch)
tree5532f1a612b9c9ad21753efb030f80bcd6de23eb /debian
parent3ceaf96bf636f93ce02f96097cce2c2f9b36c0f6 (diff)
downloadlinux-debian-3e2278ca28895753f96482f5aa87ad7b705614ed.tar.gz
d/lib/python/debian_linux/debian.py: Add Architecture field to TestsControl
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/lib/python/debian_linux/debian.py1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4ee90c2cf..d0e03c3d2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ linux (5.18.14-2) UNRELEASED; urgency=medium
* d/tests: kbuild test case depends on python3
* d/tests: Run kbuild test with default flavour if quick flavour not defined
+ * d/lib/python/debian_linux/debian.py: Add Architecture field to TestsControl
-- Ben Hutchings <benh@debian.org> Fri, 29 Jul 2022 00:43:54 +0200
diff --git a/debian/lib/python/debian_linux/debian.py b/debian/lib/python/debian_linux/debian.py
index 16a878ca7..9efb0a691 100644
--- a/debian/lib/python/debian_linux/debian.py
+++ b/debian/lib/python/debian_linux/debian.py
@@ -780,6 +780,7 @@ class TestsControl(_ControlFileDict):
_fields = collections.OrderedDict((
('Tests', str),
('Test-Command', str),
+ ('Architecture', PackageArchitecture),
('Restrictions', str),
('Features', str),
('Depends', PackageRelation),