summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch15
-rw-r--r--debian/patches/debian/version.patch4
-rw-r--r--debian/patches/rhe/0001-net-flow_dissector-dissect-into-ip-ipv6-header-insid.patch16
-rw-r--r--debian/patches/rhe/0002-net-ipv4-fix-improper-mtu-calculation-with-lwtunnel.patch16
-rw-r--r--debian/patches/rhe/0003-net-ipv6-fix-improper-mtu-calculation-with-lwtunnel.patch19
-rw-r--r--debian/patches/rhe/0004-net-add-comments-to-code-where-MTU-is-handed-incorre.patch14
-rw-r--r--debian/patches/series10
8 files changed, 55 insertions, 43 deletions
diff --git a/debian/changelog b/debian/changelog
index 97f681261..d0a06b81b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,10 @@
-linux (5.11.11-1~rhe0+5) UNRELEASED; urgency=medium
+linux (5.12.5-1~rhe0+5) UNRELEASED; urgency=medium
* Based on buster-backports (5.10.24-1~bpo10+1).
* Adjusted configs: debian/changelog and debian/config/defines.
* Added RHE patches (v5).
- -- Kazuki Yamaguchi <k@rhe.jp> Sat, 27 Feb 2021 18:44:29 +0900
+ -- Kazuki Yamaguchi <k@rhe.jp> Thu, 20 May 2021 05:39:34 +0000
linux (5.10.24-1~bpo10+1) buster-backports; urgency=medium
diff --git a/debian/patches/debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch b/debian/patches/debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
index 5525bd069..b48b26882 100644
--- a/debian/patches/debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
+++ b/debian/patches/debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
@@ -16,7 +16,7 @@ Compile resolve_btfids tool at kernel compilation start".
--- a/Makefile
+++ b/Makefile
-@@ -1067,28 +1067,6 @@ export mod_sign_cmd
+@@ -1067,39 +1067,6 @@ export mod_sign_cmd
HOST_LIBELF_LIBS = $(shell pkg-config libelf --libs 2>/dev/null || echo -lelf)
@@ -32,6 +32,17 @@ Compile resolve_btfids tool at kernel compilation start".
- endif
-endif
-
+-PHONY += resolve_btfids_clean
+-
+-resolve_btfids_O = $(abspath $(objtree))/tools/bpf/resolve_btfids
+-
+-# tools/bpf/resolve_btfids directory might not exist
+-# in output directory, skip its clean in that case
+-resolve_btfids_clean:
+-ifneq ($(wildcard $(resolve_btfids_O)),)
+- $(Q)$(MAKE) -sC $(srctree)/tools/bpf/resolve_btfids O=$(resolve_btfids_O) clean
+-endif
+-
-ifdef CONFIG_BPF
-ifdef CONFIG_DEBUG_INFO_BTF
- ifeq ($(has_libelf),1)
@@ -44,7 +55,7 @@ Compile resolve_btfids tool at kernel compilation start".
-
PHONY += prepare0
- export MODORDER := $(extmod-prefix)modules.order
+ extmod-prefix = $(if $(KBUILD_EXTMOD),$(KBUILD_EXTMOD)/)
@@ -1212,6 +1190,28 @@ uapi-asm-generic:
$(Q)$(MAKE) $(asm-generic)=arch/$(SRCARCH)/include/generated/uapi/asm \
generic=include/uapi/asm-generic
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index b292f2499..7eacd48cc 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -27,7 +27,7 @@ are set.
prepare0: archprepare
$(Q)$(MAKE) $(build)=scripts/mod
@@ -1258,6 +1258,16 @@ define filechk_version.h
- ((c) > 255 ? 255 : (c)))'
+ echo \#define LINUX_VERSION_SUBLEVEL $(SUBLEVEL)
endef
+ifneq ($(DISTRIBUTION_OFFICIAL_BUILD),)
@@ -83,8 +83,8 @@ are set.
#include <linux/seq_buf.h>
+#include <generated/package.h>
+ #include <asm/interrupt.h>
#include <asm/io.h>
- #include <asm/processor.h>
@@ -1474,8 +1475,9 @@ void show_regs(struct pt_regs * regs)
printk("NIP: "REG" LR: "REG" CTR: "REG"\n",
diff --git a/debian/patches/rhe/0001-net-flow_dissector-dissect-into-ip-ipv6-header-insid.patch b/debian/patches/rhe/0001-net-flow_dissector-dissect-into-ip-ipv6-header-insid.patch
index cb543391c..9163a8820 100644
--- a/debian/patches/rhe/0001-net-flow_dissector-dissect-into-ip-ipv6-header-insid.patch
+++ b/debian/patches/rhe/0001-net-flow_dissector-dissect-into-ip-ipv6-header-insid.patch
@@ -1,4 +1,4 @@
-From 6d562fbbf30a05a2fab230c303287b74b059b7c9 Mon Sep 17 00:00:00 2001
+From 29b2ab327dd041ab279e92019c04215970545675 Mon Sep 17 00:00:00 2001
From: Kazuki Yamaguchi <k@rhe.jp>
Date: Sun, 6 Sep 2020 04:46:10 +0900
Subject: [PATCH 1/4] net/flow_dissector: dissect into ip/ipv6 header inside
@@ -9,10 +9,10 @@ Subject: [PATCH 1/4] net/flow_dissector: dissect into ip/ipv6 header inside
1 file changed, 21 insertions(+), 5 deletions(-)
diff --git a/net/core/flow_dissector.c b/net/core/flow_dissector.c
-index 6f1adba6695f..c6608c17f9bb 100644
+index 3f36b04d86a0..fe31a4393a01 100644
--- a/net/core/flow_dissector.c
+++ b/net/core/flow_dissector.c
-@@ -404,9 +404,9 @@ static enum flow_dissect_ret
+@@ -410,9 +410,9 @@ static enum flow_dissect_ret
__skb_flow_dissect_mpls(const struct sk_buff *skb,
struct flow_dissector *flow_dissector,
void *target_container, void *data, int nhoff, int hlen,
@@ -24,7 +24,7 @@ index 6f1adba6695f..c6608c17f9bb 100644
u32 entry, label, bos;
if (!dissector_uses_key(flow_dissector,
-@@ -422,7 +422,7 @@ __skb_flow_dissect_mpls(const struct sk_buff *skb,
+@@ -428,7 +428,7 @@ __skb_flow_dissect_mpls(const struct sk_buff *skb,
if (!hdr)
return FLOW_DISSECT_RET_OUT_BAD;
@@ -33,7 +33,7 @@ index 6f1adba6695f..c6608c17f9bb 100644
label = (entry & MPLS_LS_LABEL_MASK) >> MPLS_LS_LABEL_SHIFT;
bos = (entry & MPLS_LS_S_MASK) >> MPLS_LS_S_SHIFT;
-@@ -455,7 +455,18 @@ __skb_flow_dissect_mpls(const struct sk_buff *skb,
+@@ -461,7 +461,18 @@ __skb_flow_dissect_mpls(const struct sk_buff *skb,
*entropy_label = label == MPLS_LABEL_ENTROPY;
@@ -53,7 +53,7 @@ index 6f1adba6695f..c6608c17f9bb 100644
}
static enum flow_dissect_ret
-@@ -1225,7 +1236,7 @@ bool __skb_flow_dissect(const struct net *net,
+@@ -1233,7 +1244,7 @@ bool __skb_flow_dissect(const struct net *net,
fdret = __skb_flow_dissect_mpls(skb, flow_dissector,
target_container, data,
nhoff, hlen, mpls_lse,
@@ -62,7 +62,7 @@ index 6f1adba6695f..c6608c17f9bb 100644
nhoff += sizeof(struct mpls_label);
mpls_lse++;
break;
-@@ -1748,6 +1759,11 @@ static const struct flow_dissector_key flow_keys_dissector_keys[] = {
+@@ -1771,6 +1782,11 @@ static const struct flow_dissector_key flow_keys_dissector_keys[] = {
.key_id = FLOW_DISSECTOR_KEY_GRE_KEYID,
.offset = offsetof(struct flow_keys, keyid),
},
@@ -75,5 +75,5 @@ index 6f1adba6695f..c6608c17f9bb 100644
static const struct flow_dissector_key flow_keys_dissector_symmetric_keys[] = {
--
-2.30.1
+2.31.1
diff --git a/debian/patches/rhe/0002-net-ipv4-fix-improper-mtu-calculation-with-lwtunnel.patch b/debian/patches/rhe/0002-net-ipv4-fix-improper-mtu-calculation-with-lwtunnel.patch
index ecb584cc7..75fd5793c 100644
--- a/debian/patches/rhe/0002-net-ipv4-fix-improper-mtu-calculation-with-lwtunnel.patch
+++ b/debian/patches/rhe/0002-net-ipv4-fix-improper-mtu-calculation-with-lwtunnel.patch
@@ -1,4 +1,4 @@
-From d038f3264bdd43999abc22096f3a61b0c86977a0 Mon Sep 17 00:00:00 2001
+From 79c15eb79a11a8f386bc1c72d5d9fb3c2e17b3b4 Mon Sep 17 00:00:00 2001
From: Kazuki Yamaguchi <k@rhe.jp>
Date: Wed, 24 Feb 2021 18:50:26 +0900
Subject: [PATCH 2/4] net/ipv4: fix improper mtu calculation with lwtunnel
@@ -53,10 +53,10 @@ index e20874059f82..5f9ef9082bca 100644
struct dst_metrics *ip_fib_metrics_init(struct net *net, struct nlattr *fc_mx,
diff --git a/net/ipv4/route.c b/net/ipv4/route.c
-index e26652ff7059..782f15d11909 100644
+index d635b4f32d34..ff69a9d2bdda 100644
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
-@@ -1322,16 +1322,13 @@ static unsigned int ipv4_mtu(const struct dst_entry *dst)
+@@ -1333,16 +1333,13 @@ INDIRECT_CALLABLE_SCOPE unsigned int ipv4_mtu(const struct dst_entry *dst)
if (mtu)
return mtu;
@@ -73,9 +73,9 @@ index e26652ff7059..782f15d11909 100644
- return mtu - lwtunnel_headroom(dst->lwtstate, mtu);
+ return min_t(unsigned int, mtu, IP_MAX_MTU);
}
+ EXPORT_INDIRECT_CALLABLE(ipv4_mtu);
- static void ip_del_fnhe(struct fib_nh_common *nhc, __be32 daddr)
-@@ -1395,7 +1392,7 @@ static struct fib_nh_exception *find_exception(struct fib_nh_common *nhc,
+@@ -1407,7 +1404,7 @@ static struct fib_nh_exception *find_exception(struct fib_nh_common *nhc,
}
/* MTU selection:
@@ -84,7 +84,7 @@ index e26652ff7059..782f15d11909 100644
* 2. mtu from nexthop exception
* 3. mtu from egress device
*/
-@@ -1405,11 +1402,7 @@ u32 ip_mtu_from_fib_result(struct fib_result *res, __be32 daddr)
+@@ -1417,11 +1414,7 @@ u32 ip_mtu_from_fib_result(struct fib_result *res, __be32 daddr)
struct fib_nh_common *nhc = res->nhc;
struct net_device *dev = nhc->nhc_dev;
struct fib_info *fi = res->fi;
@@ -97,7 +97,7 @@ index e26652ff7059..782f15d11909 100644
if (likely(!mtu)) {
struct fib_nh_exception *fnhe;
-@@ -1420,9 +1413,9 @@ u32 ip_mtu_from_fib_result(struct fib_result *res, __be32 daddr)
+@@ -1432,9 +1425,9 @@ u32 ip_mtu_from_fib_result(struct fib_result *res, __be32 daddr)
}
if (likely(!mtu))
@@ -110,5 +110,5 @@ index e26652ff7059..782f15d11909 100644
static bool rt_bind_exception(struct rtable *rt, struct fib_nh_exception *fnhe,
--
-2.30.1
+2.31.1
diff --git a/debian/patches/rhe/0003-net-ipv6-fix-improper-mtu-calculation-with-lwtunnel.patch b/debian/patches/rhe/0003-net-ipv6-fix-improper-mtu-calculation-with-lwtunnel.patch
index 4cc345f8f..1e433cf52 100644
--- a/debian/patches/rhe/0003-net-ipv6-fix-improper-mtu-calculation-with-lwtunnel.patch
+++ b/debian/patches/rhe/0003-net-ipv6-fix-improper-mtu-calculation-with-lwtunnel.patch
@@ -1,4 +1,4 @@
-From 786372825eaddb1339ebce3e407cf757783788ac Mon Sep 17 00:00:00 2001
+From 73e1ae0aa32bd603545df6c1283a9c22e891d445 Mon Sep 17 00:00:00 2001
From: Kazuki Yamaguchi <k@rhe.jp>
Date: Wed, 24 Feb 2021 18:50:48 +0900
Subject: [PATCH 3/4] net/ipv6: fix improper mtu calculation with lwtunnel
@@ -9,10 +9,10 @@ Subject: [PATCH 3/4] net/ipv6: fix improper mtu calculation with lwtunnel
2 files changed, 46 insertions(+), 55 deletions(-)
diff --git a/include/net/ip6_route.h b/include/net/ip6_route.h
-index 2a5277758379..ab6ae59cf7d2 100644
+index f51a118bfce8..cf7a920f3016 100644
--- a/include/net/ip6_route.h
+++ b/include/net/ip6_route.h
-@@ -310,23 +310,23 @@ static inline bool rt6_duplicate_nexthop(struct fib6_info *a, struct fib6_info *
+@@ -311,23 +311,23 @@ static inline bool rt6_duplicate_nexthop(struct fib6_info *a, struct fib6_info *
static inline unsigned int ip6_dst_mtu_forward(const struct dst_entry *dst)
{
@@ -52,10 +52,10 @@ index 2a5277758379..ab6ae59cf7d2 100644
u32 ip6_mtu_from_fib6(const struct fib6_result *res,
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
-index 188e114b29b4..506f258bfa76 100644
+index 373d48073106..bf41cd7ff368 100644
--- a/net/ipv6/route.c
+++ b/net/ipv6/route.c
-@@ -1584,11 +1584,9 @@ __rt6_find_exception_rcu(struct rt6_exception_bucket **bucket,
+@@ -1568,11 +1568,9 @@ __rt6_find_exception_rcu(struct rt6_exception_bucket **bucket,
static unsigned int fib6_mtu(const struct fib6_result *res)
{
const struct fib6_nh *nh = res->nh;
@@ -69,7 +69,7 @@ index 188e114b29b4..506f258bfa76 100644
struct net_device *dev = nh->fib_nh_dev;
struct inet6_dev *idev;
-@@ -1596,11 +1594,11 @@ static unsigned int fib6_mtu(const struct fib6_result *res)
+@@ -1580,11 +1578,11 @@ static unsigned int fib6_mtu(const struct fib6_result *res)
idev = __in6_dev_get(dev);
mtu = idev->cnf.mtu6;
rcu_read_unlock();
@@ -84,7 +84,7 @@ index 188e114b29b4..506f258bfa76 100644
}
#define FIB6_EXCEPTION_BUCKET_FLUSHED 0x1UL
-@@ -3095,25 +3093,22 @@ static unsigned int ip6_mtu(const struct dst_entry *dst)
+@@ -3081,26 +3079,23 @@ INDIRECT_CALLABLE_SCOPE unsigned int ip6_mtu(const struct dst_entry *dst)
unsigned int mtu;
mtu = dst_metric_raw(dst, RTAX_MTU);
@@ -115,6 +115,7 @@ index 188e114b29b4..506f258bfa76 100644
+ }
+ return clamp_t(unsigned int, mtu, IPV6_MIN_MTU, IP6_MAX_MTU);
}
+ EXPORT_INDIRECT_CALLABLE(ip6_mtu);
/* MTU selection:
- * 1. mtu on route is locked - use it
@@ -122,7 +123,7 @@ index 188e114b29b4..506f258bfa76 100644
* 2. mtu from nexthop exception
* 3. mtu from egress device
*
-@@ -3124,33 +3119,29 @@ u32 ip6_mtu_from_fib6(const struct fib6_result *res,
+@@ -3111,33 +3106,29 @@ u32 ip6_mtu_from_fib6(const struct fib6_result *res,
const struct in6_addr *daddr,
const struct in6_addr *saddr)
{
@@ -171,5 +172,5 @@ index 188e114b29b4..506f258bfa76 100644
struct dst_entry *icmp6_dst_alloc(struct net_device *dev,
--
-2.30.1
+2.31.1
diff --git a/debian/patches/rhe/0004-net-add-comments-to-code-where-MTU-is-handed-incorre.patch b/debian/patches/rhe/0004-net-add-comments-to-code-where-MTU-is-handed-incorre.patch
index 73cd7f05e..3f642a26f 100644
--- a/debian/patches/rhe/0004-net-add-comments-to-code-where-MTU-is-handed-incorre.patch
+++ b/debian/patches/rhe/0004-net-add-comments-to-code-where-MTU-is-handed-incorre.patch
@@ -1,4 +1,4 @@
-From a871e2f5c4a0187818dc7e1984b2cd86a2c61a4c Mon Sep 17 00:00:00 2001
+From c7399801604673ff2c4ebae5970d01c28faed339 Mon Sep 17 00:00:00 2001
From: Kazuki Yamaguchi <k@rhe.jp>
Date: Wed, 24 Feb 2021 22:36:57 +0900
Subject: [PATCH 4/4] net: add comments to code where MTU is handed incorrectly
@@ -13,7 +13,7 @@ paths.
4 files changed, 5 insertions(+)
diff --git a/net/ipv4/ip_output.c b/net/ipv4/ip_output.c
-index 2ed0b01f72f0..7870b27e62aa 100644
+index 3aab53beb4ea..7b81e8a6f071 100644
--- a/net/ipv4/ip_output.c
+++ b/net/ipv4/ip_output.c
@@ -1264,6 +1264,7 @@ static int ip_setup_cork(struct sock *sk, struct inet_cork *cork,
@@ -37,7 +37,7 @@ index 50a73178d63a..331197f08497 100644
ip_local_error(sk, EMSGSIZE, fl4->daddr, inet->inet_dport,
rt->dst.dev->mtu);
diff --git a/net/ipv6/raw.c b/net/ipv6/raw.c
-index 1f56d9aae589..4987eb7e1368 100644
+index bf3646b57c68..16add46f4b07 100644
--- a/net/ipv6/raw.c
+++ b/net/ipv6/raw.c
@@ -628,6 +628,7 @@ static int rawv6_send_hdrinc(struct sock *sk, struct msghdr *msg, int length,
@@ -49,10 +49,10 @@ index 1f56d9aae589..4987eb7e1368 100644
ipv6_local_error(sk, EMSGSIZE, fl6, rt->dst.dev->mtu);
return -EMSGSIZE;
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
-index 506f258bfa76..42b33b6cea0a 100644
+index bf41cd7ff368..6f100f25df6d 100644
--- a/net/ipv6/route.c
+++ b/net/ipv6/route.c
-@@ -2004,6 +2004,7 @@ static bool rt6_mtu_change_route_allowed(struct inet6_dev *idev,
+@@ -1988,6 +1988,7 @@ static bool rt6_mtu_change_route_allowed(struct inet6_dev *idev,
if (dst_mtu(&rt->dst) >= mtu)
return true;
@@ -60,7 +60,7 @@ index 506f258bfa76..42b33b6cea0a 100644
if (dst_mtu(&rt->dst) == idev->cnf.mtu6)
return true;
-@@ -4798,6 +4799,7 @@ static int fib6_nh_mtu_change(struct fib6_nh *nh, void *_arg)
+@@ -4786,6 +4787,7 @@ static int fib6_nh_mtu_change(struct fib6_nh *nh, void *_arg)
struct inet6_dev *idev = __in6_dev_get(arg->dev);
u32 mtu = f6i->fib6_pmtu;
@@ -69,5 +69,5 @@ index 506f258bfa76..42b33b6cea0a 100644
(mtu < arg->mtu && mtu == idev->cnf.mtu6))
fib6_metric_set(f6i, RTAX_MTU, arg->mtu);
--
-2.30.1
+2.31.1
diff --git a/debian/patches/series b/debian/patches/series
index f6ef15aa4..6fad806ad 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -53,12 +53,12 @@ debian/sched-autogroup-disabled.patch
debian/yama-disable-by-default.patch
debian/add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by-default.patch
features/all/security-perf-allow-further-restriction-of-perf_event_open.patch
-features/x86/intel-iommu-add-option-to-exclude-integrated-gpu-only.patch
-features/x86/intel-iommu-add-kconfig-option-to-exclude-igpu-by-default.patch
+# features/x86/intel-iommu-add-option-to-exclude-integrated-gpu-only.patch
+# features/x86/intel-iommu-add-kconfig-option-to-exclude-igpu-by-default.patch
# Disable autoloading/probing of various drivers by default
debian/cdc_ncm-cdc_mbim-use-ncm-by-default.patch
-debian/snd-pcsp-disable-autoload.patch
+# debian/snd-pcsp-disable-autoload.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
debian/fjes-disable-autoload.patch
@@ -126,7 +126,7 @@ bugfix/all/module-disable-matching-missing-version-crc.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch
-bugfix/all/kbuild-fix-recordmcount-dependency.patch
+# bugfix/all/kbuild-fix-recordmcount-dependency.patch
bugfix/all/tools-perf-man-date.patch
bugfix/all/tools-perf-remove-shebangs.patch
bugfix/x86/revert-perf-build-fix-libunwind-feature-detection-on.patch
@@ -136,7 +136,7 @@ bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
# bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch
# bugfix/all/bpftool-fix-version-string-in-recursive-builds.patch
-bugfix/all/tools-include-uapi-fix-errno.h.patch
+# bugfix/all/tools-include-uapi-fix-errno.h.patch
# overlay: allow mounting in user namespaces
debian/overlayfs-permit-mounts-in-userns.patch