summaryrefslogtreecommitdiffstats
path: root/debian/patches/bugfix/all/remove-config_android.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/bugfix/all/remove-config_android.patch')
-rw-r--r--debian/patches/bugfix/all/remove-config_android.patch90
1 files changed, 0 insertions, 90 deletions
diff --git a/debian/patches/bugfix/all/remove-config_android.patch b/debian/patches/bugfix/all/remove-config_android.patch
deleted file mode 100644
index 3da1197eb..000000000
--- a/debian/patches/bugfix/all/remove-config_android.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From: Christoph Hellwig <hch@lst.de>
-Date: Wed, 29 Jun 2022 17:01:02 +0200
-Subject: [2/2] remove CONFIG_ANDROID
-Origin: https://git.kernel.org/linus/1045a06724f322ed61f1ffb994427c7bdbe64647
-
-The ANDROID config symbol is only used to guard the binder config
-symbol and to inject completely random config changes. Remove it
-as it is obviously a bad idea.
-
-Acked-by: Paul E. McKenney <paulmck@kernel.org>
-Signed-off-by: Christoph Hellwig <hch@lst.de>
-Link: https://lore.kernel.org/r/20220629150102.1582425-2-hch@lst.de
-Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
----
- drivers/Makefile | 2 +-
- drivers/android/Kconfig | 9 ---------
- kernel/configs/android-base.config | 1 -
- kernel/rcu/Kconfig.debug | 3 +--
- tools/testing/selftests/filesystems/binderfs/config | 1 -
- tools/testing/selftests/sync/config | 1 -
- 6 files changed, 2 insertions(+), 15 deletions(-)
-
---- a/drivers/Makefile
-+++ b/drivers/Makefile
-@@ -176,7 +176,7 @@ obj-$(CONFIG_USB4) += thunderbolt/
- obj-$(CONFIG_CORESIGHT) += hwtracing/coresight/
- obj-y += hwtracing/intel_th/
- obj-$(CONFIG_STM) += hwtracing/stm/
--obj-$(CONFIG_ANDROID) += android/
-+obj-y += android/
- obj-$(CONFIG_NVMEM) += nvmem/
- obj-$(CONFIG_FPGA) += fpga/
- obj-$(CONFIG_FSI) += fsi/
---- a/drivers/android/Kconfig
-+++ b/drivers/android/Kconfig
-@@ -1,13 +1,6 @@
- # SPDX-License-Identifier: GPL-2.0
- menu "Android"
-
--config ANDROID
-- bool "Android Drivers"
-- help
-- Enable support for various drivers needed on the Android platform
--
--if ANDROID
--
- config ANDROID_BINDER_IPC
- tristate "Android Binder IPC Driver"
- depends on MMU
-@@ -54,6 +47,4 @@ config ANDROID_BINDER_IPC_SELFTEST
- exhaustively with combinations of various buffer sizes and
- alignments.
-
--endif # if ANDROID
--
- endmenu
---- a/kernel/configs/android-base.config
-+++ b/kernel/configs/android-base.config
-@@ -7,7 +7,6 @@
- # CONFIG_OABI_COMPAT is not set
- # CONFIG_SYSVIPC is not set
- # CONFIG_USELIB is not set
--CONFIG_ANDROID=y
- CONFIG_ANDROID_BINDER_IPC=y
- CONFIG_ANDROID_BINDER_DEVICES=binder,hwbinder,vndbinder
- CONFIG_ANDROID_LOW_MEMORY_KILLER=y
---- a/kernel/rcu/Kconfig.debug
-+++ b/kernel/rcu/Kconfig.debug
-@@ -86,8 +86,7 @@ config RCU_EXP_CPU_STALL_TIMEOUT
- int "Expedited RCU CPU stall timeout in milliseconds"
- depends on RCU_STALL_COMMON
- range 0 21000
-- default 20 if ANDROID
-- default 0 if !ANDROID
-+ default 0
- help
- If a given expedited RCU grace period extends more than the
- specified number of milliseconds, a CPU stall warning is printed.
---- a/tools/testing/selftests/filesystems/binderfs/config
-+++ b/tools/testing/selftests/filesystems/binderfs/config
-@@ -1,3 +1,2 @@
--CONFIG_ANDROID=y
- CONFIG_ANDROID_BINDERFS=y
- CONFIG_ANDROID_BINDER_IPC=y
---- a/tools/testing/selftests/sync/config
-+++ b/tools/testing/selftests/sync/config
-@@ -1,3 +1,2 @@
- CONFIG_STAGING=y
--CONFIG_ANDROID=y
- CONFIG_SW_SYNC=y