summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/version.patch')
-rw-r--r--debian/patches/debian/version.patch31
1 files changed, 8 insertions, 23 deletions
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index 71a25fa90..295dc1527 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -15,11 +15,9 @@ are set.
lib/dump_stack.c | 6 ++++--
6 files changed, 33 insertions(+), 11 deletions(-)
-diff --git a/Makefile b/Makefile
-index 0b5f8538bde5..3cc240bf69f6 100644
--- a/Makefile
+++ b/Makefile
-@@ -1168,7 +1168,7 @@ PHONY += prepare archprepare
+@@ -1195,7 +1195,7 @@ PHONY += prepare archprepare
archprepare: outputmakefile archheaders archscripts scripts include/config/kernel.release \
asm-generic $(version_h) $(autoksyms_h) include/generated/utsrelease.h \
@@ -28,8 +26,8 @@ index 0b5f8538bde5..3cc240bf69f6 100644
prepare0: archprepare
$(Q)$(MAKE) $(build)=scripts/mod
-@@ -1220,6 +1220,16 @@ define filechk_version.h
- echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))'
+@@ -1258,6 +1258,16 @@ define filechk_version.h
+ ((c) > 255 ? 255 : (c)))'
endef
+ifneq ($(DISTRIBUTION_OFFICIAL_BUILD),)
@@ -45,7 +43,7 @@ index 0b5f8538bde5..3cc240bf69f6 100644
$(version_h): FORCE
$(call filechk,version.h)
$(Q)rm -f $(old_version_h)
-@@ -1227,6 +1237,9 @@ $(version_h): FORCE
+@@ -1265,6 +1275,9 @@ $(version_h): FORCE
include/generated/utsrelease.h: include/config/kernel.release FORCE
$(call filechk,utsrelease.h)
@@ -55,8 +53,6 @@ index 0b5f8538bde5..3cc240bf69f6 100644
PHONY += headerdep
headerdep:
$(Q)find $(srctree)/include/ -name '*.h' | xargs --max-args 1 \
-diff --git a/arch/ia64/kernel/process.c b/arch/ia64/kernel/process.c
-index 96dfb9e4b16f..aa004c041bba 100644
--- a/arch/ia64/kernel/process.c
+++ b/arch/ia64/kernel/process.c
@@ -34,6 +34,7 @@
@@ -67,7 +63,7 @@ index 96dfb9e4b16f..aa004c041bba 100644
#include <asm/cpu.h>
#include <asm/delay.h>
-@@ -105,9 +106,9 @@ show_regs (struct pt_regs *regs)
+@@ -101,9 +102,9 @@ show_regs (struct pt_regs *regs)
print_modules();
printk("\n");
show_regs_print_info(KERN_DEFAULT);
@@ -79,8 +75,6 @@ index 96dfb9e4b16f..aa004c041bba 100644
printk("ip is at %pS\n", (void *)ip);
printk("unat: %016lx pfs : %016lx rsc : %016lx\n",
regs->ar_unat, regs->ar_pfs, regs->ar_rsc);
-diff --git a/arch/powerpc/kernel/process.c b/arch/powerpc/kernel/process.c
-index 4650b9bb217f..39dc2cd9fc0b 100644
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
@@ -40,6 +40,7 @@
@@ -91,7 +85,7 @@ index 4650b9bb217f..39dc2cd9fc0b 100644
#include <asm/io.h>
#include <asm/processor.h>
-@@ -1420,8 +1421,9 @@ void show_regs(struct pt_regs * regs)
+@@ -1474,8 +1475,9 @@ void show_regs(struct pt_regs * regs)
printk("NIP: "REG" LR: "REG" CTR: "REG"\n",
regs->nip, regs->link, regs->ctr);
@@ -103,8 +97,6 @@ index 4650b9bb217f..39dc2cd9fc0b 100644
printk("MSR: "REG" ", regs->msr);
print_msr_bits(regs->msr);
pr_cont(" CR: %08lx XER: %08lx\n", regs->ccr, regs->xer);
-diff --git a/arch/x86/um/sysrq_64.c b/arch/x86/um/sysrq_64.c
-index 903ad91b624f..7fdad4fc204d 100644
--- a/arch/x86/um/sysrq_64.c
+++ b/arch/x86/um/sysrq_64.c
@@ -9,6 +9,7 @@
@@ -127,8 +119,6 @@ index 903ad91b624f..7fdad4fc204d 100644
printk(KERN_INFO "RIP: %04lx:[<%016lx>]\n", PT_REGS_CS(regs) & 0xffff,
PT_REGS_IP(regs));
printk(KERN_INFO "RSP: %016lx EFLAGS: %08lx\n", PT_REGS_SP(regs),
-diff --git a/kernel/hung_task.c b/kernel/hung_task.c
-index ce76f490126c..180a97b86dc2 100644
--- a/kernel/hung_task.c
+++ b/kernel/hung_task.c
@@ -23,6 +23,7 @@
@@ -139,7 +129,7 @@ index ce76f490126c..180a97b86dc2 100644
/*
* The number of tasks checked:
-@@ -128,10 +129,11 @@ static void check_hung_task(struct task_struct *t, unsigned long timeout)
+@@ -128,10 +129,11 @@ static void check_hung_task(struct task_
sysctl_hung_task_warnings--;
pr_err("INFO: task %s:%d blocked for more than %ld seconds.\n",
t->comm, t->pid, (jiffies - t->last_switch_time) / HZ);
@@ -153,8 +143,6 @@ index ce76f490126c..180a97b86dc2 100644
pr_err("\"echo 0 > /proc/sys/kernel/hung_task_timeout_secs\""
" disables this message.\n");
sched_show_task(t);
-diff --git a/lib/dump_stack.c b/lib/dump_stack.c
-index EDITED
--- a/lib/dump_stack.c
+++ b/lib/dump_stack.c
@@ -13,6 +13,7 @@
@@ -165,7 +153,7 @@ index EDITED
static char dump_stack_arch_desc_str[128];
-@@ -45,13 +45,14 @@ void __init dump_stack_set_arch_desc(const char *fmt, ...)
+@@ -44,13 +45,14 @@ void __init dump_stack_set_arch_desc(con
*/
void dump_stack_print_info(const char *log_lvl)
{
@@ -182,6 +170,3 @@ index EDITED
if (dump_stack_arch_desc_str[0] != '\0')
printk("%sHardware name: %s\n",
---
-2.27.0
-