aboutsummaryrefslogtreecommitdiffstats
path: root/openssl.spec
diff options
context:
space:
mode:
authorRichard Levitte <levitte@openssl.org>2001-03-22 12:14:37 +0000
committerRichard Levitte <levitte@openssl.org>2001-03-22 12:14:37 +0000
commit1d7fb4f0c5844d91aa43029e2e1ddd09aefa28c9 (patch)
treed0a3d40dff1ca930c2f862523fff6608ea37629b /openssl.spec
parent81a6c7817f69b73386a4a9b3eb8929c375ee3bf7 (diff)
downloadopenssl-1d7fb4f0c5844d91aa43029e2e1ddd09aefa28c9.tar.gz
Remove redundant operations and update version info.
Diffstat (limited to 'openssl.spec')
-rw-r--r--openssl.spec35
1 files changed, 13 insertions, 22 deletions
diff --git a/openssl.spec b/openssl.spec
index 501151ab47..4d68d705ae 100644
--- a/openssl.spec
+++ b/openssl.spec
@@ -1,8 +1,8 @@
%define libmaj 0
%define libmin 9
-%define librel 6
-#%define librev
-Release: 2
+%define librel 7
+#%define librev a
+Release: 1
%define openssldir /var/ssl
@@ -94,7 +94,7 @@ perl util/perlpath.pl /usr/bin/perl
./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-ppc shared
%endif
%ifarch alpha
-./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-alpha-gcc shared
+./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-alpha shared
%endif
LD_LIBRARY_PATH=`pwd` make
LD_LIBRARY_PATH=`pwd` make rehash
@@ -102,33 +102,16 @@ LD_LIBRARY_PATH=`pwd` make test
%install
rm -rf $RPM_BUILD_ROOT
-make install MANDIR=/usr/man INSTALL_PREFIX="$RPM_BUILD_ROOT"
+make MANDIR=/usr/man INSTALL_PREFIX="$RPM_BUILD_ROOT" install
# Rename manpages
for x in $RPM_BUILD_ROOT/usr/man/man*/*
do mv ${x} ${x}ssl
done
-## Install RSAref stuff
-#install -m644 rsaref/rsaref.h $RPM_BUILD_ROOT/usr/include/openssl
-#install -m644 libRSAglue.a $RPM_BUILD_ROOT/usr/lib
-
# Make backwards-compatibility symlink to ssleay
ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
-# Install shared libs
-install -m644 libcrypto.a $RPM_BUILD_ROOT/usr/lib
-install -m755 libcrypto.so.%{libmaj}.%{libmin}.%{librel} $RPM_BUILD_ROOT/usr/lib
-install -m644 libssl.a $RPM_BUILD_ROOT/usr/lib
-install -m755 libssl.so.%{libmaj}.%{libmin}.%{librel} $RPM_BUILD_ROOT/usr/lib
-(
- cd $RPM_BUILD_ROOT/usr/lib
- ln -sf libcrypto.so.%{libmaj}.%{libmin}.%{librel} libcrypto.so.%{libmaj}
- ln -sf libcrypto.so.%{libmaj}.%{libmin}.%{librel} libcrypto.so
- ln -sf libssl.so.%{libmaj}.%{libmin}.%{librel} libssl.so.%{libmaj}
- ln -sf libssl.so.%{libmaj}.%{libmin}.%{librel} libssl.so
-)
-
%clean
rm -rf $RPM_BUILD_ROOT
@@ -167,6 +150,14 @@ ldconfig
ldconfig
%changelog
+* Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
+- Removed redundant subsection that re-installed libcrypto.a and libssl.a
+ as well. Also remove RSAref stuff completely, since it's not needed
+ any more.
+* Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
+- Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
+ libssl.so.0.9.6. As well as the subsection that created symlinks for
+ these. make install handles all this.
* Sat Oct 21 2000 Horms <horms@vergenet.net>
- Make sure symlinks are created by using -f flag to ln.
Otherwise some .so libraries are copied rather than