aboutsummaryrefslogtreecommitdiffstats
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL25
1 files changed, 25 insertions, 0 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
new file mode 100644
index 0000000000..f9998e0a61
--- /dev/null
+++ b/perl/Makefile.PL
@@ -0,0 +1,25 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'OPTIMIZE' => '-g',
+ 'DISTNAME' => 'SSLeay-perl5-0.8.5',
+ 'NAME' => 'SSLeay',
+ 'VERSION_FROM' => 'SSLeay.pm',
+ 'LIBS' => ['-L.. -lssl -lcrypto'],
+ 'DEFINE' => '',
+ 'INC' => '-I../include',
+ 'C' => ['callback.c'],
+ 'H' => ['p5SSLeay.h'],
+ 'OBJECT' => " SSLeay.o bio.o bn.o cipher.o digest.o err.o
+ ssl.o x509.o",
+ 'XS' => { 'SSLeay.xs' => 'SSLeay.c',
+ 'bio.xs' => 'bio.c',
+ 'bn.xs' => 'bn.c',
+ 'cipher.xs' => 'cipher.c',
+ 'digest.xs' => 'digest.c',
+ 'err.xs' => 'err.c',
+ 'ssl.xs' => 'ssl.c',
+ 'x509.xs' => 'x509.c',
+ }
+ );