aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authornormal <normal@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-01-09 08:26:38 +0000
committernormal <normal@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-01-09 08:26:38 +0000
commite8f40bd8f83e1b22ef9c22f0e5d7a1fc0b07f94c (patch)
tree3e7402abb3e992b67b7d6f8a5fcca7f9c5d23f10 /configure.ac
parent60bb4fcdf615e20b39d7726b6ff7c0d84b7c8475 (diff)
downloadruby-e8f40bd8f83e1b22ef9c22f0e5d7a1fc0b07f94c.tar.gz
thread_pthread: remove HAVE_PTHREAD_ATTR_INIT ifdefs
ifdefs make code confusing for my easily-confused mind :< These were added for NaCL support in r36022, and we dropped NaCL in r60374. There are more #ifdefs to remove... [ruby-core:84758] [Misc #14342] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@61719 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90ce91bf7c..37e50fe47d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2963,7 +2963,7 @@ AS_IF([test x"$enable_pthread" = xyes], [
AC_DEFINE(NON_SCALAR_THREAD_ID)
])
AC_CHECK_FUNCS(sched_yield pthread_attr_setinheritsched \
- pthread_attr_get_np pthread_attr_getstack pthread_attr_init \
+ pthread_attr_get_np pthread_attr_getstack \
pthread_get_stackaddr_np pthread_get_stacksize_np \
thr_stksegment pthread_stackseg_np pthread_getthrds_np \
pthread_cond_init pthread_condattr_setclock pthread_condattr_init \