aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 14:40:55 +0000
committerk0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 14:40:55 +0000
commitc6d0892fa2296586d4ab614cd8c4748dfaba7d64 (patch)
tree89450015d0485af0ecfe456cb7ec2be236ac5198 /configure.ac
parent52007caea0c8a568cb598c92647e133bd3b02fd2 (diff)
downloadruby-c6d0892fa2296586d4ab614cd8c4748dfaba7d64.tar.gz
configure.ac: disable native-fiber for MinGW
because it had already been SEGV-ed in pull request'S CI https://ci.appveyor.com/project/ruby/ruby/builds/20427065/job/32oahrcd58b8ubb1 and has never worked on trunk either. Please make sure it does not SEGVs on your MinGW environment or pull request before enabling native fiber on MinGW. appveyor.yml: reverted commits to make CI green with native fiber test/excludes/_appveyor/msys2/TestArray.rb: ditto test/excludes/_appveyor/msys2/TestEnumerable.rb: ditto test/excludes/_appveyor/vs/TestArray.rb: ditto git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65892 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index dcbaf0d623..5a221f6bf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2345,12 +2345,13 @@ AS_CASE(["$target_cpu-$target_os"],
AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
AC_LIBOBJ([coroutine/x86/Context])
],
- [x64-mingw32], [
- AC_MSG_RESULT(win64)
- COROUTINE_H=coroutine/win64/Context.h
- AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
- AC_LIBOBJ([coroutine/win64/Context])
- ],
+ # TODO: Enable this after AppVeyor msys2 build succeeds
+ # [x64-mingw32], [
+ # AC_MSG_RESULT(win64)
+ # COROUTINE_H=coroutine/win64/Context.h
+ # AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
+ # AC_LIBOBJ([coroutine/win64/Context])
+ # ],
[*], [
AC_MSG_RESULT(no)
]