aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Abraham <mark.j.abraham@gmail.com>2019-11-05 14:31:52 +0100
committerNobuyoshi Nakada <nobu@ruby-lang.org>2019-11-06 00:31:52 +0900
commit07f2062c8ffecc774a4ebc1f39ff2c4940592be4 (patch)
treecc14e6012b83a73bc3c4621e9a77d75bfcf57bf8 /configure.ac
parent6aacef49483ed83697dc013a4b33606338dffd39 (diff)
downloadruby-07f2062c8ffecc774a4ebc1f39ff2c4940592be4.tar.gz
Improve string literal concatenation for C++11
Downstream C++ projects that compile with C++11 or newer and include the generated config.h file issue compiler warnings. Both C and C++ compilers do string-literal token pasting regardless of whitespace between the tokens to paste. C++ compilers since C++11 require such spaces, to avoid ambiguity with the new style of string literals introduced then. This change fixes such projects without affecting core Ruby.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 67ce5f99d2..0435f124ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3797,8 +3797,8 @@ AS_IF([test "${universal_binary-no}" = yes ], [
AC_SUBST(UNIVERSAL_ARCHNAMES, "${universal_archnames}")
AC_SUBST(UNIVERSAL_INTS, "${ints}")
AC_DEFINE_UNQUOTED(RUBY_PLATFORM_OS, "${target_os}")
- AC_DEFINE_UNQUOTED(RUBY_ARCH, "universal-"RUBY_PLATFORM_OS)
- AC_DEFINE_UNQUOTED(RUBY_PLATFORM, "universal."RUBY_PLATFORM_CPU"-"RUBY_PLATFORM_OS)
+ AC_DEFINE_UNQUOTED(RUBY_ARCH, "universal-" RUBY_PLATFORM_OS)
+ AC_DEFINE_UNQUOTED(RUBY_PLATFORM, "universal." RUBY_PLATFORM_CPU "-" RUBY_PLATFORM_OS)
], [
arch="${target_cpu}-${target_os}"
AC_DEFINE_UNQUOTED(RUBY_PLATFORM, "$arch")