aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYusuke Endoh <mame@ruby-lang.org>2019-08-25 23:08:13 +0900
committerYusuke Endoh <mame@ruby-lang.org>2019-08-25 23:08:13 +0900
commit365e5b38a9ca24116a9c3133e0a0e8ce230ccb02 (patch)
treec5db129ca5690edb38adf76eaeb21a4d2f46a5d0 /configure.ac
parent11f7c30fa7812388b8919453b92fdf5613db22dd (diff)
downloadruby-365e5b38a9ca24116a9c3133e0a0e8ce230ccb02.tar.gz
configure.ac: Improve icc_version guessing for non-icc environment
icc_version was wrongly defined as "__ICC" on non-icc C compiler, which caused a warning: ``` ./configure: line 8211: test: __ICC: integer expression expected ``` This change adds a sed commend to delete "__ICC".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cd9f039bfe..cb3553b647 100644
--- a/configure.ac
+++ b/configure.ac
@@ -239,7 +239,7 @@ AS_IF([test "$GCC" = yes], [
gcc_minor=`echo =__GNUC_MINOR__ | $CC -E -xc - | sed '/^=/!d;s///'`
test -n "$gcc_major" || gcc_major=0
test -n "$gcc_minor" || gcc_minor=0
- icc_version=`echo =__ICC | $CC -E -xc - | sed '/^=/!d;s///'`
+ icc_version=`echo =__ICC | $CC -E -xc - | sed '/^=/!d;s///;/^__ICC/d'`
test -n "$icc_version" || icc_version=0
# RUBY_APPEND_OPTIONS(XCFLAGS, ["-include ruby/config.h" "-include ruby/missing.h"])
], [