aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authornagachika <nagachika@ruby-lang.org>2020-07-05 07:03:14 +0900
committernagachika <nagachika@ruby-lang.org>2020-07-05 07:03:14 +0900
commit9720591043003a5262c8f3e1c1720771bc77488b (patch)
tree09161f1aca61cd367c22ada77655b232d91f834f /configure.ac
parent799c5766a4dc215d139d2c26ac68636f43a64fbf (diff)
downloadruby-9720591043003a5262c8f3e1c1720771bc77488b.tar.gz
merge revision(s) 75802bcff1b941818832f0145071f7ce9c843d8d:
configure: suppress icc warnings Every time a pointer to/from VALUE conversion happens, these two warnings are issued: - warning #1684: conversion from pointer to same-sized integral type (potential portability problem) - warning #2312: pointer cast involving 64-bit pointed-to type Thank you, but we are well aware of the "potential portability problem". Let us ignore them all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f1ed36bb96..ccf47a1da9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -530,7 +530,7 @@ AS_CASE(["$GCC:${warnflags+set}:${extra_warnflags:+set}:"],
-Wsuggest-attribute=format \
-Wsuggest-attribute=noreturn \
-Wunused-variable \
- -diag-disable=175,188,2259 \
+ -diag-disable=175,188,1684,2259,2312 \
$extra_warnflags \
; do
AS_IF([test "$particular_werror_flags" != yes], [