aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKoichi Sasada <ko1@atdot.net>2019-10-20 16:16:54 +0900
committerKoichi Sasada <ko1@atdot.net>2019-10-20 16:16:54 +0900
commit9e07dfd253f5086b306d5e32d3ef4238a8510bc2 (patch)
tree73878cc19af276b20bf5ff5efcecb756d8611051 /configure.ac
parenta236eaa762137d7cb32b8311e0ef9a74bbb0f385 (diff)
downloadruby-9e07dfd253f5086b306d5e32d3ef4238a8510bc2.tar.gz
show BASERUBY version at configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6ebd5e31b1..653f3bb651 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,7 @@ AC_ARG_VAR([cxxflags], [additional CXXFLAGS (ignored when CXXFLAGS is given)])
: "environment section" && {
HAVE_BASERUBY=yes
+BASERUBY_VERSION=
AC_ARG_WITH(baseruby,
AS_HELP_STRING([--with-baseruby=RUBY], [use RUBY as baseruby; RUBY is the pathname of ruby]),
[AS_CASE(["$withval"],
@@ -34,6 +35,7 @@ AC_ARG_WITH(baseruby,
AS_IF([test "$HAVE_BASERUBY" = yes -a "`RUBYOPT=- $BASERUBY -e 'print 42' 2>/dev/null`" = 42], [
AS_IF([test "`RUBYOPT=- $BASERUBY --disable=gems -e 'print 42' 2>/dev/null`" = 42], [
BASERUBY="$BASERUBY --disable=gems"
+ BASERUBY_VERSION=`$BASERUBY -v`
])
$BASERUBY -C "$srcdir" tool/downloader.rb -d tool -e gnu config.guess config.sub >&AS_MESSAGE_FD
], [
@@ -4063,6 +4065,7 @@ config_summary "JIT support" "$MJIT_SUPPORT"
config_summary "man page type" "$MANTYPE"
config_summary "search path" "$search_path"
config_summary "static-linked-ext" ${EXTSTATIC:+"yes"}
+config_summary "BASERUBY -v" "$BASERUBY_VERSION"
echo ""
echo "---"
])