aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2019-12-03 14:51:14 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2019-12-03 14:51:14 +0900
commite42d9d8df87f58b9bfa65647249822df25851375 (patch)
tree8beaec943f56d48a1246e486968c6a73d6693bec /configure.ac
parent9165fcdfa309052a2adc3c6100ab24204de6c2d1 (diff)
downloadruby-e42d9d8df87f58b9bfa65647249822df25851375.tar.gz
Fixed the inverted condition
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6c8311dbe8..6cea43d0c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -579,7 +579,7 @@ AS_IF([test "$GCC" = yes], [
AS_HELP_STRING([--disable-fortify-source],
[disable -D_FORTIFY_SOURCE=2 option, which causes link error on mingw]),
[fortify_source=$enableval])
- AS_IF([test "x$fortify_source" = xno], [
+ AS_IF([test "x$fortify_source" != xno], [
RUBY_TRY_CFLAGS(-D_FORTIFY_SOURCE=2, [RUBY_APPEND_OPTION(XCFLAGS, -D_FORTIFY_SOURCE=2)])
])