aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-02-20 06:50:36 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-02-20 06:50:36 +0000
commit032d0a4cf7cd000214ad0347242b09f7039edbcc (patch)
treec32d86599c89ddc68042f3d434e5386bf83f5648 /configure.in
parent05a2cd709f4b223c1e3c32d7699b31d7dab20591 (diff)
downloadruby-032d0a4cf7cd000214ad0347242b09f7039edbcc.tar.gz
* configure.in: check if -fstack-protector is really available.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@34700 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2b56b749d4..7b14caa571 100644
--- a/configure.in
+++ b/configure.in
@@ -505,6 +505,9 @@ if test "$GCC" = yes; then
],
[
RUBY_TRY_CFLAGS(-fstack-protector, [stack_protector=yes], [stack_protector=no])
+ if test "x$stack_protector" = xyes; then
+ RUBY_TRY_LDFLAGS(-fstack-protector, [], [stack_protector=broken])
+ fi
])
if test "x$stack_protector" = xyes; then
RUBY_APPEND_OPTION(XCFLAGS, -fstack-protector)