aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-02-28 14:14:44 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-02-28 14:14:44 +0000
commit0927f830411d0120042319ad2e5fa5020ed7d8da (patch)
treee108b40eb87915f80f893c9668f08301d76211e1 /configure.in
parent7b91046b293e9d26e3d7451f1be52cd028a41b70 (diff)
downloadruby-0927f830411d0120042319ad2e5fa5020ed7d8da.tar.gz
configure.in: fold summary
* configure.in: fold long lines in configuration summary git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53966 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in71
1 files changed, 39 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index a14b074201..2442e19d87 100644
--- a/configure.in
+++ b/configure.in
@@ -4532,40 +4532,47 @@ AC_OUTPUT
}
}
+AS_IF([${FOLD+:} false], [], [
+AS_IF([test "`echo abcdefg hijklmno | fold -s -w10 | sed 1d`" = hijklmno], [FOLD="fold"], [FOLD=])
+])
+AS_REQUIRE_SHELL_FN([config_summary],
+ [AS_FUNCTION_DESCRIBE([config_summary], [NAME, VAL], [configuration summary])],
+ [AS_IF([test -z "$2"], [], [
+ AS_ECHO_N([" * $1: "]) | head -c26
+ AS_IF([test "$FOLD"], [
+ echo "$2" | fold -s -w50 |
+ sed '1!s/^/ /;$!s/$/\\/'
+ ], [echo "$2"])
+ ])]
+)
+
echo "---"
echo "Configuration summary for $RUBY_BASE_NAME version $RUBY_PROGRAM_VERSION"
echo ""
-echo " * Installation prefix: $prefix"
-echo " * exec prefix: $exec_prefix"
-echo " * arch: $arch"
-echo " * site arch: $sitearch"
-echo " * RUBY_BASE_NAME: $RUBY_BASE_NAME"
-echo " * ruby lib prefix: $rubylibprefix"
-echo " * site libraries path: $rubysitearchprefix"
-echo " * vendor path: $vendordir"
-echo " * target OS: $target_os"
-echo " * compiler: $CC"
-echo " * with pthread: $enable_pthread"
-echo " * enable shared libs: $ENABLE_SHARED"
-echo " * dynamic library ext: $DLEXT"
-if test "$(eval echo $cflags)" != ""; then
-echo " * CFLAGS: $(eval echo $cflags)"
-fi
-if test "$(eval echo $cppflags)" != ""; then
-echo " * CPPFLAGS: $cppflags"
-fi
-echo " * LDFLAGS: $LDFLAGS"
-echo " * strip command: $STRIP"
-echo " * install doc: $install_doc"
-echo " * man page type: $MANTYPE"
-if test "$kcode" != ""; then
-echo " * kcode: $kcode"
-fi
-if test "$search_path" != ""; then
-echo " * search path: $search_path"
-fi
-if test -n "$EXTSTATIC"; then
-echo " * static-linked-ext: yes"
-fi
+config_summary "Installation prefix" "$prefix"
+config_summary "exec prefix" "$exec_prefix"
+config_summary "arch" "$arch"
+config_summary "site arch" "$sitearch"
+config_summary "RUBY_BASE_NAME" "$RUBY_BASE_NAME"
+config_summary "enable shared" "$enable_shared"
+config_summary "ruby lib prefix" "$rubylibprefix"
+config_summary "site libraries path" "$rubysitearchprefix"
+config_summary "vendor path" "$vendordir"
+config_summary "target OS" "$target_os"
+config_summary "compiler" "$CC"
+config_summary "with pthread" "$enable_pthread"
+config_summary "enable shared libs" "$ENABLE_SHARED"
+config_summary "dynamic library ext" "$DLEXT"
+config_summary "CFLAGS" "$cflags"
+config_summary "CPPFLAGS" "$cppflags"
+config_summary "LDFLAGS" "$LDFLAGS"
+config_summary "optflags" "$optflags"
+config_summary "debugflags" "$debugflags"
+config_summary "warnflags" "$warnflags"
+config_summary "strip command" "$STRIP"
+config_summary "install doc" "$install_doc"
+config_summary "man page type" "$MANTYPE"
+config_summary "search path" "$search_path"
+config_summary "static-linked-ext" ${EXTSTATIC:+"yes"}
echo ""
echo "---"