aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-02-06 17:56:47 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-02-06 17:56:47 +0000
commit0a3fc607c17085ed53070833645727d65ac4d1b0 (patch)
tree3657a09aa5b3b501c95f5136a00e8fb7fa9ebb17 /configure.in
parent325890497e2dbadfb52ebe0888d617729da32115 (diff)
downloadruby-0a3fc607c17085ed53070833645727d65ac4d1b0.tar.gz
Revert "check __int64_t and __int128_t"
This reverts commit r53750. Those types seems to be for C++, and breaks old GCC. http://rubyci.s3.amazonaws.com/c64b/ruby-trunk/log/20160206T130202Z.diff.html.gz git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53757 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 1cb1ef6cb6..040484b5ab 100644
--- a/configure.in
+++ b/configure.in
@@ -1473,8 +1473,6 @@ RUBY_CHECK_SIZEOF(long, [int], [ILP LP])
RUBY_CHECK_SIZEOF(long long)
RUBY_CHECK_SIZEOF(__int64)
RUBY_CHECK_SIZEOF(__int128)
-RUBY_CHECK_SIZEOF(__int64_t)
-RUBY_CHECK_SIZEOF(__int128_t)
RUBY_CHECK_SIZEOF(off_t)
RUBY_CHECK_SIZEOF(void*, [int long "long long"], [ILP LP LLP])
RUBY_CHECK_SIZEOF(float)
@@ -2011,8 +2009,6 @@ typedef $1 t; int s = sizeof(t) == 42;])],
["$ac_cv_sizeof_long_long"], [ rb_cv_type_$1="m4_if([$3], [], [], [$3 ])long long"],
["$ac_cv_sizeof___int64"], [ rb_cv_type_$1="m4_if([$3], [], [], [$3 ])__int64"],
["$ac_cv_sizeof___int128"], [ rb_cv_type_$1="m4_if([$3], [], [], [$3 ])__int128"],
- ["$ac_cv_sizeof___int64_t"], [ rb_cv_type_$1="m4_if([$3], [], [], [$3 ])__int64_t"],
- ["$ac_cv_sizeof___int128_t"], [ rb_cv_type_$1="m4_if([$3], [], [], [$3 ])__int128_t"],
[ rb_cv_type_$1=no])])])
if test "${rb_cv_type_$1}" != no; then
AC_DEFINE([HAVE_]AS_TR_CPP($1), 1)