aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-11-25 03:36:13 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-11-25 03:36:13 +0000
commit311a9eb0c53fd147544d4a71de4ab5d7aa4c29cb (patch)
tree2f331d82b5fd9a6c9117195adfdcf2e6570b3005 /configure.in
parent0bd9072758f5c65edee17244e428e81e227f3af0 (diff)
downloadruby-311a9eb0c53fd147544d4a71de4ab5d7aa4c29cb.tar.gz
configure.in: color to ifchange
* configure.in: pass --color to ifchange from CONFIGURE_TTY for reconfig. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@52747 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index dccac086a8..8d36819671 100644
--- a/configure.in
+++ b/configure.in
@@ -4340,7 +4340,10 @@ guard=INCLUDE_RUBY_CONFIG_H
grep -v "^#define PACKAGE_" confdefs.h
echo "#endif /* $guard */"
} | tr -d '\015' |
-${srcdir}/tool/ifchange "${config_h}" -
+(
+ if test "x$CONFIGURE_TTY" = xyes; then color=--color; else color=; fi
+ exec ${srcdir}/tool/ifchange $color "${config_h}" -
+)
tr -d '\015' < largefile.h > confdefs.h
rm largefile.h