aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKazuki Yamaguchi <k@rhe.jp>2016-03-17 18:30:02 +0900
committerKazuki Yamaguchi <k@rhe.jp>2016-04-01 01:20:10 +0900
commit4124dc8714f0d6e8f9b19cc138d630291292a846 (patch)
treee4f994ce284c7922ea6061e445b4dd005677858f /configure.in
parentf0060b81c672e5f80ffed1b3a979d218b49e1021 (diff)
downloadruby-4124dc8714f0d6e8f9b19cc138d630291292a846.tar.gz
improve git repository detectionfix/git-worktree-detection
* configure.in (AC_CONFIG_FILES): $srcdir/.git can be a file pointing the real git_dir, such as when the git working tree is a "linked working tree" (a working tree created by git-worktree). So use git-rev-parse --git-dir to check if $srcdir is the top-level of a git repository, not just checking if the $srcdir/.git directory does exist or not. * tool/change_maker.rb: use tool/vcs.rb to detect VCS. This used to have its own VCS detection code, while we have tool/vcs.rb. * tool/vcs.rb (detect): remove code duplication
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a96ed71344..b32187bee9 100644
--- a/configure.in
+++ b/configure.in
@@ -4464,10 +4464,12 @@ AC_CONFIG_FILES(Makefile, [
:
elif svn info "$srcdir" > /dev/null 2>&1; then
VCS='svn'
- elif test -d "$srcdir/.git/svn"; then
- VCS='git svn'
- elif test -d "$srcdir/.git"; then
- VCS='git'
+ elif git_dir=`git --work-tree="$srcdir" --git-dir="$srcdir/.git" rev-parse --git-dir 2>/dev/null`; then
+ if test -d "$git_dir/svn"; then
+ VCS='git svn'
+ else
+ VCS='git'
+ fi
else
VCS='echo cannot'
fi