aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-04-02 07:27:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-04-02 07:27:12 +0000
commit51bcbca236aa1af540766c85e99d93d33492a2d9 (patch)
tree0ee8ce1d2ac6ee179128a00285a10a93629dde4a /configure.in
parent7363ffbfca1ec750e2b94794c913390e4197909f (diff)
downloadruby-51bcbca236aa1af540766c85e99d93d33492a2d9.tar.gz
rbconfig.rb: use program version
* common.mk, tool/mkconfig.rb: check the running ruby version in rbconfig.rb with the program version, as RUBY_VERSION has never been affected by --with-ruby-version option. [ruby-core:68639] [Bug #11002] * configure.in (LIBRUBY_DLDFLAGS): compatibility_version must be valid version numbers, not an arbitrary string. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@50152 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index db37cd6644..8a23f4ebc1 100644
--- a/configure.in
+++ b/configure.in
@@ -3567,7 +3567,7 @@ AS_CASE("$enable_shared", [yes], [
fi
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-install_name '${libprefix}'/$(LIBRUBY_SO)'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-current_version $(MAJOR).$(MINOR).$(TEENY)'
- LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-compatibility_version $(ruby_version)'
+ LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-compatibility_version $(RUBY_PROGRAM_VERSION)'
if test "$visibility_option" = ld; then
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-Wl,-unexported_symbol,_Init_*'
LIBRUBY_DLDFLAGS="$LIBRUBY_DLDFLAGS "'-Wl,-unexported_symbol,_ruby_static_id_*'