aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-02-28 14:14:42 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-02-28 14:14:42 +0000
commit7b91046b293e9d26e3d7451f1be52cd028a41b70 (patch)
treecdbe887ce0fa559c690bc615da924421eedeecd8 /configure.in
parent1a9bc87ab7fab1313b1fdb4ea6b1a0a9e44affc0 (diff)
downloadruby-7b91046b293e9d26e3d7451f1be52cd028a41b70.tar.gz
configure.in: summary
* configure.in: Add summary to end of configure output. [Fix GH-1277] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53965 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c9a2349379..a14b074201 100644
--- a/configure.in
+++ b/configure.in
@@ -4531,3 +4531,41 @@ AC_CONFIG_FILES($ruby_pc:template/ruby.pc.in,
AC_OUTPUT
}
}
+
+echo "---"
+echo "Configuration summary for $RUBY_BASE_NAME version $RUBY_PROGRAM_VERSION"
+echo ""
+echo " * Installation prefix: $prefix"
+echo " * exec prefix: $exec_prefix"
+echo " * arch: $arch"
+echo " * site arch: $sitearch"
+echo " * RUBY_BASE_NAME: $RUBY_BASE_NAME"
+echo " * ruby lib prefix: $rubylibprefix"
+echo " * site libraries path: $rubysitearchprefix"
+echo " * vendor path: $vendordir"
+echo " * target OS: $target_os"
+echo " * compiler: $CC"
+echo " * with pthread: $enable_pthread"
+echo " * enable shared libs: $ENABLE_SHARED"
+echo " * dynamic library ext: $DLEXT"
+if test "$(eval echo $cflags)" != ""; then
+echo " * CFLAGS: $(eval echo $cflags)"
+fi
+if test "$(eval echo $cppflags)" != ""; then
+echo " * CPPFLAGS: $cppflags"
+fi
+echo " * LDFLAGS: $LDFLAGS"
+echo " * strip command: $STRIP"
+echo " * install doc: $install_doc"
+echo " * man page type: $MANTYPE"
+if test "$kcode" != ""; then
+echo " * kcode: $kcode"
+fi
+if test "$search_path" != ""; then
+echo " * search path: $search_path"
+fi
+if test -n "$EXTSTATIC"; then
+echo " * static-linked-ext: yes"
+fi
+echo ""
+echo "---"