aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-03-01 11:21:18 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-03-01 11:21:18 +0000
commitee4cb17b98fa5efe9c81f08743f3c165dd677547 (patch)
tree518b0947cf7b533958a68a18454dbfb7703625fb /configure.in
parentea2d631a76f5249f2839d1a9d0c48c1c97ee4422 (diff)
downloadruby-ee4cb17b98fa5efe9c81f08743f3c165dd677547.tar.gz
configure.in: restore convertible type
* configure.in (RUBY_REPLACE_TYPE): restore convertible type from cached variable, so that configured results will be stable. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@49794 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2824993da7..365538c2ae 100644
--- a/configure.in
+++ b/configure.in
@@ -1475,7 +1475,10 @@ AC_DEFUN([RUBY_REPLACE_TYPE], [dnl
[
t=INT])
rb_cv_[$1]_convertible=${u}${t}])
- test "${AS_TR_SH(ac_cv_type_[$1])}" = "yes" && n="$1"
+ AS_CASE(["${rb_cv_[$1]_convertible}"],
+ [*LL], [n="long long"],
+ [*LONG], [n="long"],
+ [n="int"])
AS_CASE("${rb_cv_[$1]_convertible}", [U*], [u=+1], [u=-1])
AC_DEFINE_UNQUOTED(rb_[$1], $n)
AC_DEFINE_UNQUOTED([SIGNEDNESS_OF_]AS_TR_CPP($1), $u)