aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-04-22 07:03:32 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-04-22 07:03:32 +0000
commit31049a6fd6648b26e1210f1eb482f6efc94ad5a2 (patch)
tree30462e32f7ebdcf96fd907760a1fce110ac5dc22 /configure.in
parentdf5b0f317bbddd326f87fe94730c1d582e7bd8e4 (diff)
downloadruby-31049a6fd6648b26e1210f1eb482f6efc94ad5a2.tar.gz
* configure.in: use AC_USE_SYSTEM_EXTENSIONS.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@16138 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4ab2446e73..aeb8ddf6fb 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT()
-AC_PREREQ(2.58)
+AC_PREREQ(2.60)
AC_ARG_WITH(baseruby,
[ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
@@ -243,8 +243,7 @@ AC_PROG_MAKE_SET
AC_PROG_INSTALL
# checks for UNIX variants that set C preprocessor variables
-AC_AIX
-AC_MINIX
+AC_USE_SYSTEM_EXTENSIONS
AC_SUBST(RM, ['rm -f'])
AC_SUBST(CP, ['cp'])
@@ -1624,7 +1623,6 @@ fi
MINIDLNOBJ=dln.o
case "$target_os" in
linux*)
- XCFLAGS="$XCFLAGS -D_GNU_SOURCE=1"
;;
netbsd*)
CFLAGS="$CFLAGS -pipe"