aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-09-08 09:08:15 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-09-08 09:08:15 +0000
commit4f26f3b8902a59ec27070f8cf1fd038561894f4d (patch)
tree8f51964341539072b73e7d7ffdae95c6179cca9e /configure.in
parent275d1a12e6eeae346731bd9373aeff934d270db0 (diff)
downloadruby-4f26f3b8902a59ec27070f8cf1fd038561894f4d.tar.gz
* configure.in: modify program_prefix only if specified
--program-prefix. * configure.in: don't generate ext/extmk.rb. * Makefile.in: execute directly $(srcdir)/ext/extmk.rb. remove -Cext option, "Dir::chdir 'ext'" in ext/extmk.rb. * {win32,bccwin32}/Makefile.sub: ditto. * instruby.rb: ditto. * ext/extmk.rb: renamed from ext/extmk.rb.in. * lib/mkmf.rb (module Logging): create log files (mkmf.log) in each extension module directories. * ext/extmk.rb: ditto. * lib/mkmf.rb (macro_defined?): new method. * ext/.cvsignore: remove extmk.rb. * ext/*/.cvsignore: add "*.def". git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@2819 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 357eb74314..d299c633bb 100644
--- a/configure.in
+++ b/configure.in
@@ -27,6 +27,9 @@ then
(it is also a good idea to do 'make clean' before compiling))
fi
+if test "$program_prefix" = NONE; then
+ program_prefix=
+fi
AC_CANONICAL_TARGET
dnl checks for fat-binary
@@ -1172,5 +1175,5 @@ else
fi
: > confdefs.h
-AC_CONFIG_FILES([$FIRSTMAKEFILE Makefile ext/extmk.rb])
+AC_CONFIG_FILES([$FIRSTMAKEFILE Makefile])
AC_OUTPUT