aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-12-13 07:41:01 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-12-13 07:41:01 +0000
commit770c6a5d4c94db32b35b2cb213d5005a5fa0f2e4 (patch)
treeddc407b8e31c06009dfc7b5e2c5c6bf6fb38033d /configure.in
parent40a8c0054732ada2b76a0d560e8a000581c73254 (diff)
downloadruby-770c6a5d4c94db32b35b2cb213d5005a5fa0f2e4.tar.gz
configure.in: make BASERUBY fullpath
* configure.in (BOOTSTRAPRUBY): make BASERUBY full path before building ruby to get rid of unexpectedly invoking built ruby. [ruby-core:72065] [Bug #11807] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53073 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5207fad759..cbefd7c1db 100644
--- a/configure.in
+++ b/configure.in
@@ -43,7 +43,7 @@ AC_ARG_WITH(baseruby,
AS_CASE(["$withval"],[*ruby*],[BASERUBY=$withval],[AC_MSG_ERROR(need ruby)])
],
[
- BASERUBY="ruby"
+ AC_PATH_PROG([BASERUBY], [ruby], [false])
])
if test "`RUBYOPT=- $BASERUBY -e 'print 42' 2>/dev/null`" = 42; then
if test "`RUBYOPT=- $BASERUBY --disable=gems -e 'print 42' 2>/dev/null`" = 42; then