aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-11-05 05:11:33 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-11-05 05:11:33 +0000
commitef8139db13537ab2e4ef7d141076cfedb3cf8282 (patch)
treed84f3a8f241c9842c1ac7d58defcdfa3a5cd4777 /configure.in
parent62ede28373fe20cb72963e71b8589ffac016224a (diff)
downloadruby-ef8139db13537ab2e4ef7d141076cfedb3cf8282.tar.gz
common.mk: update unicode data only if BASERUBY is available
* common.mk (lib/unicode_normalize/tables.rb): do nothing unless BASERUBY is available. MINIRUBY cannot load extension libraries, so cannot update Unicode data. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48278 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c6504ba112..6ac18b8d10 100644
--- a/configure.in
+++ b/configure.in
@@ -46,10 +46,13 @@ if test "`RUBYOPT=- $BASERUBY -e 'p 42' 2>/dev/null`" = 42; then
BASERUBY="$BASERUBY --disable=gems"
fi
$BASERUBY -C "$srcdir/tool" downloader.rb -e gnu config.guess config.sub
+ HAVE_BASERUBY=yes
else
BASERUBY="echo executable host ruby is required. use --with-baseruby option.; false"
+ HAVE_BASERUBY=no
fi
AC_SUBST(BASERUBY)
+AC_SUBST(HAVE_BASERUBY)
AC_DEFUN([RUBY_MINGW32],
[AS_CASE(["$host_os"],