aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-11-13 10:53:20 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-11-13 10:53:20 +0000
commitfffeb611217ffd16f9aad5d89741f84082ee06d1 (patch)
treecc155227604b44fed5048776a6f930d597d0c96a /configure.in
parent9d59b0d1a1883222ab62d3d8671650296776c816 (diff)
downloadruby-fffeb611217ffd16f9aad5d89741f84082ee06d1.tar.gz
* configure.in: do not override CC if set.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@1832 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 390daf410a..83a90037d9 100644
--- a/configure.in
+++ b/configure.in
@@ -11,14 +11,14 @@ AC_SUBST(TEENY)
dnl checks for alternative programs
AC_ARG_WITH(gcc, [--without-gcc never use gcc], [
case $withval in
- no) CC=cc
+ no) : ${CC=cc}
without_gcc=yes;;
- yes) CC=gcc
+ yes) : ${CC=gcc}
without_gcc=no;;
*) CC=$withval
without_gcc=$withval;;
esac], [
- CC=gcc
+ : ${CC=gcc}
without_gcc=no])
dnl If the user switches compilers, we can't believe the cache
if test ! -z "$ac_cv_prog_CC" -a ! -z "$CC" -a "$CC" != "$ac_cv_prog_CC"