aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-02-06 08:25:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-02-06 08:25:00 +0000
commit65806ccb721251cdae290fa000be4185ff466398 (patch)
treeebb65d5fff67b76965e52428f9f4aaa8fc8666c1 /configure.in
parentd77119bfe463a3eeb7b3b6995dec697ebb6be85d (diff)
downloadruby-65806ccb721251cdae290fa000be4185ff466398.tar.gz
* configure.in: keep old config.h unless changed.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@2050 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 28e91b8af7..afa29a70e0 100644
--- a/configure.in
+++ b/configure.in
@@ -1093,8 +1093,12 @@ if test "$search_path" != ""; then
AC_DEFINE_UNQUOTED(RUBY_SEARCH_PATH,"$search_path")
fi
-echo "creating config.h"
-tr -d '\015' < confdefs.h > config.h
+if test -f config.h && tr -d '\015' < confdefs.h | cmp -s config.h -; then
+ echo "config.h unchanged"
+else
+ echo "creating config.h"
+ tr -d '\015' < confdefs.h > config.h
+fi
: > confdefs.h
AC_OUTPUT($FIRSTMAKEFILE Makefile ext/extmk.rb)