aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-04-23 01:43:35 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-04-23 01:43:35 +0000
commite2b54072b5f3b93a15056efdf54697f36f674eb8 (patch)
tree6dec2c009a44aaf4ecb029aaa2263efc4bcc7023 /configure.in
parentc9bbb3a8b8c2c09bd42af684319bcfb1983a6a6c (diff)
downloadruby-e2b54072b5f3b93a15056efdf54697f36f674eb8.tar.gz
* configure.in: disable rubygems not to load rbconfig.rb before
fake.rb. [ruby-core:44492][Bug #6329] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35431 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2df023b57d..e40354af89 100644
--- a/configure.in
+++ b/configure.in
@@ -19,8 +19,13 @@ AC_ARG_WITH(baseruby,
[
BASERUBY="ruby"
])
-test "`RUBYOPT=- $BASERUBY -e 'p 42' 2>/dev/null`" = 42 ||
+if test "`RUBYOPT=- $BASERUBY -e 'p 42' 2>/dev/null`" = 42; then
+ if test "`RUBYOPT=- $BASERUBY --disable=gems -e 'p 42' 2>/dev/null`" = 42; then
+ BASERUBY="$BASERUBY --disable=gems"
+ fi
+else
BASERUBY="echo executable host ruby is required. use --with-baseruby option.; false"
+fi
AC_SUBST(BASERUBY)
AC_DEFUN([RUBY_MINGW32],