aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-18 05:56:34 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-18 05:56:34 +0000
commit4d02a2bf81e349c6d957f9be7ad9140adc922751 (patch)
tree1a5dc128c3f5ebef416f947513863e85b2a6c9bb /configure.in
parent453321f78613f0acc80d08bd6a9cdf6280f0791d (diff)
downloadruby-4d02a2bf81e349c6d957f9be7ad9140adc922751.tar.gz
configure.in: honor GIT env
* configure.in (--with-git): honor environment variable GIT if set. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58388 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 74f79b35d2..dedde6d83f 100644
--- a/configure.in
+++ b/configure.in
@@ -60,13 +60,13 @@ fi
AC_SUBST(BASERUBY)
AC_SUBST(HAVE_BASERUBY)
-GIT=git
+: ${GIT=git}
HAVE_GIT=yes
AC_ARG_WITH(git,
AS_HELP_STRING([--without-git], [never use git]),
[AS_CASE([$withval],
[no], [GIT=never-use HAVE_GIT=no],
- [yes], [GIT=git],
+ [yes], [],
[GIT=$withval])])
AS_IF([test x"$HAVE_GIT" = xyes], [command -v "$GIT" > /dev/null || HAVE_GIT=no])
AC_SUBST(GIT)