aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-05-08 17:44:51 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2016-05-08 17:44:51 +0000
commit51af3690dd225e1e3bf6f5c687d2e05cd9c85fce (patch)
treed37adb13ec69829960f21d187cbd689d780338eb /configure.in
parent735b11cd170935199f7970c039c46176ef7b2c9a (diff)
downloadruby-51af3690dd225e1e3bf6f5c687d2e05cd9c85fce.tar.gz
* configure.in: check function attirbute const and pure,
and define CONSTFUNC and PUREFUNC if available. Note that I don't add those options as default because it still shows many false-positive (it seems not to consider longjmp). * vm_eval.c (stack_check): get rb_thread_t* as an argument to avoid duplicate call of GET_THREAD(). git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@54952 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 48ee91c323..8fb0643312 100644
--- a/configure.in
+++ b/configure.in
@@ -1800,6 +1800,8 @@ AC_DEFUN([RUBY_TYPE_ATTRIBUTE], [dnl
])
])
+RUBY_FUNC_ATTRIBUTE(const, CONSTFUNC)
+RUBY_FUNC_ATTRIBUTE(pure, PUREFUNC)
RUBY_FUNC_ATTRIBUTE(noreturn, NORETURN)
RUBY_FUNC_ATTRIBUTE(deprecated, DEPRECATED)
RUBY_FUNC_ATTRIBUTE(deprecated("by "@%:@n), DEPRECATED_BY(n,x), rb_cv_func_deprecated_by)