aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-10-04 15:43:58 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-10-04 15:43:58 +0000
commit71968ee56cbf07457e3e7ea254780e7dab137217 (patch)
treeeaff3053ef3e0a9a4ae2baab74736518532ae817 /configure.in
parent600d445e4dc51ed2fd971bc9320a76489297ffe0 (diff)
downloadruby-71968ee56cbf07457e3e7ea254780e7dab137217.tar.gz
configure.in: add ruby-runner only if needed
* configure.in (PREP): add ruby-runner only if needed to pass the environment variable for library path as /bin/sh clears it. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@52028 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7d0f1e8557..31c624413b 100644
--- a/configure.in
+++ b/configure.in
@@ -3704,6 +3704,15 @@ if test "$EXEEXT" = .exe; then
AC_SUBST(EXECUTABLE_EXTS)
fi
+AS_CASE("$cross_compiling:${LIBPATHENV}", [yes:* | no:], [], [
+ AC_MSG_CHECKING(whether wrapper for $LIBPATHENV is needed)
+ AS_IF([env ${LIBPATHENV}=/lib /bin/sh -c ': ${'${LIBPATHENV}'?}' 2>/dev/null],
+ [AC_MSG_RESULT(no)],
+ [PREP="$PREP"' ruby-runner$(EXEEXT)'
+ AC_MSG_RESULT(yes)]
+ )
+])
+
AC_ARG_ENABLE(dtrace,
AS_HELP_STRING([--enable-dtrace],
[enable DTrace for tracing inside ruby. enabled by default on systems having dtrace]),