aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authormame <mame@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-05-20 13:00:41 +0000
committermame <mame@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-05-20 13:00:41 +0000
commit33710d4581a1eec94778e2041ca55e3f08849bd0 (patch)
tree238026a5a22bcbb29125d58cd507a89972cf7f59 /configure.in
parent41e800f6a8eb00147a366161b0893d97bb01b6b0 (diff)
downloadruby-33710d4581a1eec94778e2041ca55e3f08849bd0.tar.gz
Add coverage measurement mode by using gcov
This experimental feature is only for Ruby-core team, not for casual users. Usage: `./configure --enable-gcov && make && make exam && make gcov` git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58817 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cc008dbebf..609ce1f25a 100644
--- a/configure.in
+++ b/configure.in
@@ -4063,6 +4063,14 @@ AC_SUBST(DTRACE_REBUILD)
AC_SUBST(DTRACE_OPT)
AC_SUBST(LIBRUBY_A_OBJS)
+AC_ARG_ENABLE(gcov,
+ AS_HELP_STRING([--enable-gcov], [enable coverage measurement by gcov]),
+ [gcov=yes])
+if test x"$gcov" = xyes; then
+ CFLAGS="$CFLAGS -coverage"
+ LDFLAGS="$LDFLAGS -coverage"
+fi
+
RUBY_SETJMP_TYPE
}
{ # build section