aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKazuki Yamaguchi <k@rhe.jp>2017-04-17 09:53:41 +0900
committerKazuki Yamaguchi <k@rhe.jp>2017-09-09 16:32:30 +0900
commit08855fc77fccdeccf8035d9c3d07dc2bcd53c844 (patch)
tree7010548a72adfd22d1f0693f2259db60d61db249 /configure.in
parent1b36737982f66432cbb4424ae606e9f9411eded9 (diff)
downloadruby-08855fc77fccdeccf8035d9c3d07dc2bcd53c844.tar.gz
configure.in: don't check for atan2l() and atan2f()
We don't use them directly. The check was initially introduced to check whether the compiler conforms to C99 or not. This is not necessary since r45930.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 3410632e98..4bd773552c 100644
--- a/configure.in
+++ b/configure.in
@@ -2312,7 +2312,6 @@ AC_CHECK_FUNCS(_longjmp) # used for AC_ARG_WITH(setjmp-type)
# we don't use _setjmp if _longjmp doesn't exist.
test x$ac_cv_func__longjmp = xno && ac_cv_func__setjmp=no
AC_CHECK_FUNCS(arc4random_buf)
-AC_CHECK_FUNCS(atan2l atan2f)
AC_CHECK_FUNCS(chroot)
AC_CHECK_FUNCS(chsize)
AC_CHECK_FUNCS(clock_gettime)
@@ -2532,8 +2531,7 @@ void qsort_r(void *base, size_t nmemb, size_t size,
])
AC_CACHE_CHECK(whether atan2 handles Inf as C99, rb_cv_atan2_inf_c99, [
- AS_IF([test $ac_cv_func_atan2f:$ac_cv_func_atan2l = yes:yes], [
- AC_TRY_RUN([
+ AC_TRY_RUN([
@%:@include <math.h>
@%:@ifdef HAVE_UNISTD_H
@%:@include <unistd.h>
@@ -2554,9 +2552,7 @@ main(int argc, char **argv)
],
[rb_cv_atan2_inf_c99=yes],
[rb_cv_atan2_inf_c99=no],
- [AS_CASE($target_os, [mingw*|mswin*], [rb_cv_atan2_inf_c99=no], [rb_cv_atan2_inf_c99=yes])]
- )
- ], [rb_cv_atan2_inf_c99=no])
+ [AS_CASE($target_os, [mingw*|mswin*], [rb_cv_atan2_inf_c99=no], [rb_cv_atan2_inf_c99=yes])])
])
AS_IF([test "x$rb_cv_atan2_inf_c99" = xyes], [AC_DEFINE(ATAN2_INF_C99)])